HP 2710p - coming from Ubuntu

So I tried Ubuntu for several weeks and while i used it, i never could get decent battery life out of it, never could get my stylus to work (i have a tablet pc) and overall it just seemed unpolished.

i am using opensuse 11-64 bit now on it and wow…simply wow. my stylus works through simply setting it up with the gui. my battery life is 4 hours out of the box and opensuse is beautiful also. (GNOME version)

however - one thing eludes me. i have a webcam integrated into my lid and in ubuntu it worked with cheese right away. but in opensuse i have been trying to get it working for a few days, and after reading lots of threads and trying lots of drivers i still cant get it going. in cheese with one set of drivers, the sceen would be black but when i took a pic it would show up, but most of the time - nothing happens. if anyone has a direction i should go, i’d love to hear it.

and man o man - opensuse has such a more polished feel than ubuntu. but getting used to rpm packages instead of the deb’s of ubuntu is hard.

RPM’s are hard to get used to…
but I think the fact that things
are solid and more polished can
be a testament to the strict
dependencies found on this distro…

Anyway, cheese IS working if you
can see the picture…I have had
many problems with Gstreamer
in the past, but its been solid
for at least a month now. From
Yast > Install Software look at
your currently installed version
of gstreamer, and see if downgrading
(by clicking on the bottom right
package name and number, you should
be prompted with other choices,
see if that changes anything…
for me it did until the problem
was fixed…also, do you have
usb-utils installed? If not,
install it, and post your output of


I have an HP Pavilion DV2000, w/
a Chicony cam…just wondering what you’re running…

Good Luck…

I have HP 2710p, but I have installed 32-bit version of Opensuse 11.
Webcamera works fine in skype and luvcview, but not with cheese
(It just shows some colorful rectangles - kind of precision color table).