HP 2600n - doesn't work

I even downloaded all driver packages. but still, this printer does not work. it is a network printer. I entered the IP address but I can’t seem to make it work. worked in mandriva so I know for a fact it is doable.

any ideas?

moveright wrote:
> I even downloaded all driver packages. but still, this printer does not
> work. it is a network printer. I entered the IP address but I can’t
> seem to make it work. worked in mandriva so I know for a fact it is
> doable.

Does your HP2600n have a JetDirect interface? If so, you should connect to
lpd://<IP ADDR>/raw. Use YaST => Hardware => Printer to create the connection.
My printer is an hP2200dn, which connects this way.


no idea if it has the jet direct interface. how would I know?

I just can’t believe that out of the 1000’s of drivers listed, mine is not one of them. I went to hp.com but they only have windows and mac drivers. this is weird. in mandriva, I just clicked “add new” printer, typed int he IP address and boom. it was done. there has to be some way to do this.

but seriously, what is jet direct?

but seriously, what is jet direct?

a google search would suggest some of the following

SM - HP Jetdirect print servers - overview

HP Jetdirect 175x Print Server series overview - HP Small & Medium Business products

is there anything in this recent posting

Printing over Network to HP with Jetdirect card - Page 2 - openSUSE Forums

that may be of use to you?

I ended up finding foo2hp or something like that. it works. I really wanted to use hplip but it was just too much for me to understand and get working. all is well. thanks for the help!

well done;

if you spell out for others what you did, it may be very helpful for others following in your wake

Hello Friends

ofcourse… yes, yes… I’m such a noob that I naturally don’t think I can help anyone else, or maybe I’m just scared to. but none the less, it did work for me, so I will spell it out kindergarten style which is what I need to have done for me to understand. for all those searching this forum for help and you keep getting advice too complicated for your linux virgin mind, here comes a how to for the HP 2600n!!!

lol. come one, that was kinda funny. I read and read and found out that there are only a couple printers which are not supported in linux by drivers and the reason is because they have some retarded communication method/algorythm, I don’t know… they just plain out don’t friggin’ work. LUCKILY, some really smart people made a universal driver for the few printers (hp2600n being one of them) that don’t work and they called it “foo2hp”.

ok, first I went to foo2hp: a linux printer driver for ZJS protocol (e.g. HP Color LaserJet 1600/2600n, CP1215) and read a bunch of garbage I didn’t udnerstand.

then I saw the instructions but did not know what “wget” did. but I saw a direct download link for the foo2hp. I downloaded the file and unpacked it on the desktop to a folder. then I followed the directions AFTER the unpack part.

here is the whole shabang:

Download and Install

Click the link, or cut and paste the whole command line below to download the driver.

        $ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz

Now unpack it:

        $ tar zxf foo2zjs.tar.gz
        $ cd foo2zjs

Now compile and install it. The INSTALL file contains more detailed instructions; please read it now.

        $ make

    Get .ICM profiles for color correction.
    Select the model number for your printer:
        $ ./getweb 2600n     # Get HP LaserJet 2600n .ICM files
        $ ./getweb 1600      # Get HP LaserJet 1600 .ICM files
        $ ./getweb 1215      # Get HP LaserJet CP1215 .ICM files

    Install driver, foomatic XML files, and extra files:
        $ su		OR	$ sudo make install
        # make install

    (Optional) If you use CUPS, restart the spooler:
        # make cups		OR	$ sudo make cups

I have no idea how this works but I typed in code and it did work. I did not do the optional CUPS thing cuz I have no clue what it is (that’s really my thing isn’t it…? having no clue?)

anyhow. all was well afterwards, I just found my printer by typing the IP in, and used the foo driver and BAMN works great. btw, don’t mind that bit about how it “doesn’t work very well with printing colors” that’s all a bunch of garbage, the thing works PERFECT.

I Still have no idea why when I used mandriva2009one I just needed to install package “system-config-printer” and this worked but with SUSE, I’ve had to download foo2hp.

oh well, not understanding is what I do best.

thanks; good work