HP 210 Netbook shuns 13.1, will she patch it up with 12.3 or seek a new relationship?

My Netbook was happy with 12.3, then along came 13.1 with the promise of a new and improved life. An update was arranged and seemed to progress well. However when they met again at reboot time it all went wrong before they had really said hello.
Total blank before the login screen showed itself. Modeset/nomodeset made no difference. They simply did not want to know each other.
Vowing to start again, a full install was tried with the same results.

Is it the end of the road for this relationship?

Certainly 13.1 has proved compatible with other boxes in the family group. Debian and Slack have dated her, but will those relationships last as long as 12.3.

So, is this a clean install or upgrade? Did the install complete both install and config? When you restart openSUSE, does the display just go blank? What graphics does this computer claim to have?

Thank You,

You can run the installer, so the installed version should be able to run as well.

I thought that as well! It seems that the machine has other ideas. 12.3 was quite happy with the machine, as is Slackware 14.1 and Debian 6.0. Cannot find any log files that shine any light on what is happening (using GParted). The boot splash screen loads but does not reach the login dialog. Escaping shows a “welcome to” message but does not progress any further. Tried setting default runlevel to give text login. Same results. Tried to install a xen option but it complained about the xen hypervisor. (I was hoping another layer may prevent chafing.) I do not know yet whether I could ssh or telnet to it. I’ll have to decide how desperate I am.

So far installed 13.1 on an AMD XP2200 machine and an ancient Thinkpad (1.8GHz) with no problems. Other machines yet to be processed include a Pentium Prescott 3GHz and an AMD Phenom 965 (4x3.4GHz) machine. I would be a little annoyed if I trashed the last two. I seem to remember 11.2 was a little flaky in a similar fashion.

Thanks for the postings.

It started as an upgrade, and became a clean install. I think the graphics come curtesy of a lttle known company called Intel at 1024x600 24bit. All normal until booting the system when it stops. I say stops rather than hangs as the escape button can toggle text/graphics splash, so some processes still live. Switching consoles is similarly futile.

I will sleep on it. Maybe enlightenment will come.

Thanks for the post.

Sounds to me like your graphics driver, a known problem.

Especially when I see the 1024x600 mentioned.

Try booting with the Failsafe option.

Or, still at the Grub window, hit “e” to edit the line and add “nomodeset”

(without the quotes)


Been there, done that, NBG (no b****y good). Recognises a gma500 same as previous 12.3. 12.3 was quite happy with the resolution and 13.1 displays splash and graphics. I would say not a video issue. Has a feel of memory problem, but it installed on a Thinkpad with 512Mb while the HP has 2Gb. Disks have swap partitions anyway. Should not be a problem. Maybe kernel has problems with Intel Atom processor.

I may just give upgrades to 13.1 the elbow until definitive answers are forthcoming.


Could still be a video driver problem there is known problems with the Intel driver shipped with 13.1 but there is a updated one ready to install.

If you can boot to a terminal then as root do zypper up which should get the new Intel driver.

And you are right it could be memory if you are installing KDE or gnome but you still should get to a graphic login in any case which to me says video problem.

To give you an idea of where the failure occurs, if you look in a boot.log file such as produced when 12.3 boots :-

Mounting root /dev/disk/by-id/ata-Hitachi_HDT721010SLA360_STF607MH37KASK-part1
mount -o rw,data=journal,acl,user_xattr -t ext4 /dev/disk/by-id/ata-Hitachi_HDT721010SLA360_STF607MH37KASK-part1 /root

Welcome to e0;32mopenSUSE 12.3 (Dartmouth) (x86_64)e0m!

     Starting Collect Read-Ahead Data... 
     Starting Replay Read-Ahead Data...

The init program (13.1) issues the welcome message and stops. As this is way before a login process is started, or any real graphics are deployed something much more fundemental is going on, or rather off. No evidence of logs being written to disk at this stage.

Hey Ho!
(Wonder where my Kernel in a Nutshell has crawled off to)

To wrap it up, decided to use Debian 7.0 on that machine.

It may be wheezy, but it certainly ain’t coffin.

Thanks for the posts.