[HowTo] Brother MFC printer solutions for Leap and Tumbleweed

I have a Brother MFC-J625DW printer that I connect to over WiFI. It normally works perfectly on Ubuntu and Arch with the manufacturer’s Linux drivers. But for the life of me I couldn’t get it to work either on Leap 42.1 or on Tumbleweed. Stranger still, I could print a test page from the yast2-printers, and I could also print from Wine apps (notepad), but I couldn’t print a test page from system-config-printers and I also couldn’t print front LibreOffice or gedit or any other normal program. The details in the print queue for the failed job said “filter failed”. The solution: poppler-tools needs to be installed.

On another installation, the documents I tried to print didn’t give any errors, not even in the CUPS error_log. They just simply did not print. But I finally found an old, out of date Brother printer driver page that reminds that the drivers are 32-bit, and so on a 64-bit system the 32-bit compatibility libs are necessary. That’s what I was missing. The solution: installing libstdc++6-32bit with its dependencies fixed it.

Have a Brother MFC 7360N and installed it, scanner and fax drivers with Brothers linux-brprinter-installer-2.0.0-1 using MFC-7306 for the printer name. Was amazed at how well it worked, It d/led the proper drivers and just worked. May want to try different names such as leaving off the MFC but it did work for me

In my case, the drivers were installed and the printer was detected, I was just missing those dependencies I mentioned.