HowTo autostart kinternet in 11.2/kde4?

Hello List, I see there was one unanswered post on this in 08!

I got autostart working on 11.2/gnome, but I’ve switch to kde4.3.1.

Duncan on the kde list suggested to manually save a session, but in the session manager there’s not a clue how to manually save a session.

In gnome I wrote a shell script to start kinternet, but the script has to start after smpppd. That script starts too soon in kde4.

The reasoon kinternet doesn’t start with the “restart on login” box, is a kde3 app.

Can I get some help here to manually save a session, or to write a script that can wait for smpppd?

I have already tried kinternet --kicker, but apparetly kicker starts before smpppd.

The script I wrote starts kinternet but with this error:

Error - KInternet
Connection to local and remote server
refused. Maybe smpppd is not running
or you are not member of the group “dialout”.
Also check the server settings in
the dialog “Various Settings”.

The error to the calling shell looks like this:

Starting kinternet --kicker
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
buildsycoca running…

Please help on this on! Heboland

For KDE4, use qinternet.

Are you running an actual modem or pppoe? You should just be
able to use the Networkmanager to connect?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 21:25, 3 users, load average: 0.20, 0.26, 0.26
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Thanks Akoellh, malcolmlewis,
I installed qinternet and it is an improvement. It does restart on login from a parent of kinit.

On login, qinternet gets the same error messages as kinternet and starts without a connection to the server. At that point the only menu option is “reconnect to server”.

I am connecting with a modem directly (/dev/stty0) as modem:0.

I’m ready to try the network manager if it will work with a dial-up modem.

Right now I have the Network Devices > Configuration settings set to Ifup and ivpc4 instead of 6. Those setting disable the network manager.

malcolmlewis, what would you suggest for trying a modem connection with the network manager? Do I have to use ivpc6?


You need to stick to IPV4, but there is an application called
modem-manager which I think you should be using these days. What
happens if you delete the modem in YaST, set the system back to use the
NetworkManager. Login as your user and right-click on the
NetworkManager icon and try setting up there.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 8 days 0:51, 3 users, load average: 0.32, 0.24, 0.28
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

You can get Kinternet to restart two ways:

  1. Get Kinternet running and an applet appears in the systray. Right click thae applet and choose Settings → put a X in “start on login to kde”
  2. put kinternet in the autostart directory located at /home/username/.kde4/Autostart

Thank you swerdna,
I think I’ve tried both methods you mentioned, both unsuccessfully.

kde4 ignores the “start on login” box on kinternet, so no restart.

I used the kde4 > “desktop configuration” > advanced > autostart. In there I use the script section to start a script I wrote that invokes kinternet.

This invocation starts kinternet on login, but with the connection error I mentioned above. Is the autostart you mentioned different than the one I used?

Apparently smpppd isn’t started yet when autostart calls kinternet. The same problem happens with kinit starting qinternet.

I can live with qinternet, but I will try network manager yet before I caputulate. Heboland

You set the daemon smpppd to start first by going to Yast → System → System Services Runlevels → smpppd set to “enable” = yes

That might have been the entire problem (maybe). Once you set that, it’s possible that kinternet will respond to the first option I gave above.

Thanks swerdna, malcolmlewis,

swerdna, I’ll get back to you after I log off and try your suggestion.

malcolmlewis, I took the first network manager conversion baby step. I changed from Ifup to NM. When the Yast > Network Devices > Newtork Configuration updated, it came up with the error “Network not running”.

I OKed that, but it gives me the impression that I have to be continuously connected. Dial-up here seldom lasts for longer than a half hour. Will I need a continuous connection with NM?


Replying to myself,
swerdna, smpppd was started and running. This is the status from the beginning - didn’t change anything!

Start the smpppd for internet and dial-up connections.
Service will be started in the following runlevels: 2,3,5.

Smpppd starts automatically, but apparently after kinternet or qinternet start. What’s needed is a script that waits for smpppd.

If you tell me how to detect smpppd, I’ll attempt a script that waits to call qinternet until smpppd is started. The magic has to be a semiphore file or a lock file. Any hints from you?

malcolmlewis, I see that my baby networking step has had consequences already! Back to Yast > Network > Network Settings, I got this warning:

Network is currently controlled by NetworkManager and its setting cannot be dedited by Yast.
To edit the setting, use NetworkManager connection editor, or switch the network setup method to Traditionial method with ifup.

Can you guide me to NetworkManager? I think I remember seeing it by accident, but haven’t been able to find my way back to it aganin. Heboland

In the Metwork Devices->Network Settings, Global options tab you can
select either ‘Traditional’ or ‘NetworkMager’ to suit your requirements.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 8 days 4:36, 3 users, load average: 0.47, 0.80, 0.65
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Thank you malcolmlewis,

I’ve already been to Network Setting and enabled the Network Manager. That is now requiring me to use the NetworkManager connection editor - see above!

Can you tell me where to find that network editor? Heboland

Just right-click on the tray icon, in the list there is an option to
‘edit connections’

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 8 days 6:22, 3 users, load average: 0.47, 0.57, 0.54
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

malcolmlewis, swerdna, I had to search this new thing to find my post! Glad I got this posted before the “improved” version landed!

Looks like swerdna has dropped off short of giving a hint for detecting smpppd running from a script.

malcolmlewis, you have to back up a step here and pick me up! I assume that you are referring to a NetworkManager tray icon?

Maybe I have to install NetworkManager? Maybe there is some generic icon in the panel called tray icon?

To decide if the NetworkManager is installed, what do I have to “which” for in the terminal, IE which NM?

Please help me track down this NetworkManager! Heboland

Maybe a simpler (albeit inelegant) solution would be to insert a delay in your script before calling kinternet, something like

wait *n*

to wait n seconds.

If you switch to NetworkManager in YaST, it should automatically start
the next time you log into your Desktop and be in the panel somewhere.
When it’s disabled via traditional ifup, it removes it’s self.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 4:34, 3 users, load average: 0.51, 0.39, 0.36
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Thanks brunomcl, malcolmlewis,
brunomcl, I’ll get back to the script after this NM stuff!

malcolmlewis, I found the NM icon in the system tray, butI have my doubts that this is going to work with a dial-up modem!

The first NM menu is Enable Wireless or Manage Connections. Since I don’t have wireless, I take the Manage Connections. Help isn’t working here!

At this level the choices are Network Connections and Other. Other deals with GUI details like icons. Network Connetions has Wired, VPN, or DSL that aren’t grayed out. Wired is the only choice here since I don’t have DSL or VPN.

Wired Connections have the choice of Etherhet, IP Address, or 802. IP Address is the only possible here. That has possible choices of Automatic DCHP and manual. Both of these seem to require an IP address that I don’t have.

Did I miss something here? Heboland

Replying to myself regarding a startup script for kinternet!

brunomcl thanks for your input. What you suggested would work with the right value for “n”.

Let me offer what I came up with. It works for me. It’s simple, but it’s hardcoded for the location of the smpppd semiphore.


This script is itended to start kinternet

Wait for smpppd to start before invoking kinternet

until -e /var/run/smpppd/control ]
#print “smpppd is running”
#print “starting kinternet”
exit 0

I’m a zshell user, but this code is bournes compatible. Turns out that when smpppd is running the control file exists, but not if smpppd is disabled.

kinternet is necessary rather than qinternet because nothing else starts kinternet like kinit. qinternet gets restarted improperly by the session manager if it is running when the session exits. That is at least my version of it.

I welcome criticism (hopefully constructive) from the list regarding this script. It’s quite possible the empty do-done list isn’t required. Heboland

Replying again to myself for completeness,

The above script is invoked by the 11.2/kde4.3.1 Configure Desktop > Advanced > Autostart (script subset).

I put some timers into the above script to collect information about it’s operation. On my Pentium 4 the “until loop” executes 224 passes after Autostart invokes the script and smpppd starts.

In wall-clock time that is seven seconds! Heboland

That’s an elegant fix for your special problem.

Just for interest, for others with delay problems. Suppose you have an action that you need to delay, if the action is written in a script, e.g., you can run that script with a delay of N seconds by putting this line in your crontable:

@reboot; sleep N; /path_to/

For example I have a windows share that won’t mount via cifs until the network settles so I mount it with that technique.