How to zypper in from specific repo?

I don’t know what I’m doing wrong here.
“sudo zypper in kde4-k3b --repo Packman” returns “’-repo’ is not a valid package or capability name.”
“sudo zypper in kde4-k3b -r 6” returns
"‘r’ not found.
‘6’ not found.
Resolving package dependencies…

The following NEW package is going to be installed:
As far as I can understand from the man page, this is supposed to work.
“zypper se kde4-k3b --repo Packman” works pretty much as I expected.
Using the install software gui, I see on the versions tab that the ONLY version is the packman one.
I realize I could use the gui or just “sudo zypper in kde4-k3b kde4-k3b-codecs”, but I want to know what I’m doing wrong or if this simply doesn’t work as it seems to say it will in the manpage.
Yep, my packman repo is #6 aliased Packman.

I don’t know if it helps, but I found these examples:

zypper in amarok packman:libxine1 # install libxine1 from packman and amarok from any repo

sudo zypper in education:bluefish

Thank you.
I found sudo zypper in --repo Packman kde4-k3b kde4-k3b-codecs" worked with no error messages. I thought I had tried every permutation.
I’ll experiment with your suggestions, tho.
I guess I should install something available from more than one repo to verify.

zypper install -r 25 kde4-k3b
instead. The command (install) and the command option (-r / --repo) must be placed in front of the argument (kde4-k3b)


Yes, I think the repo name has to come first.

Zypper/Usage/11.1 - openSUSE

and of course

man zypper

Yes. Looking at the man page again…what I overlooked is…
install (in) [options] <name|capability|rpm_file_uri> …
while for list updates it’s
list-updates (lu) [options]
and I use “zypper lu -r” alot. Trained my brain wrong.
Thanks again, guys.