How to use WPA2-Enterprise on KDE Plasmoid-NetworkManager

I had some difficulty getting Plasmoid to work on to connect to a WPA2-Enterprise Network.
The Cert file is in DER format which is something like this “XXXX.cer”
After I filed a bug report I got a respond to try the updated Plasmoid from this Repo:
Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4
To use it you have to first install your certificate in openssl using terminal.
First copy the certificate into the ssl directory (In OpenSUSE it is /etc/ssl/certs/)

  1. sudo cp path_to_file /etc/ssl/certs/

Then install it (If you don’t do this it will fail) Source:

2)sudo ln -s filename_of_certificate openssl x509 -hash -noout -in filename_of_certificate.0

3)Then after that when using Plasmoid to connect check the box use system certificate.

It should work like it worked for me but I still think certificate handling needs a lot of improvement.
Pointing the cert directly from plasmoid does not work.

Wow this worked for me as well. I was having the network manager keep asking for certificate bug … where Gnome networkmanager did not have any problems.
Thank you so much! Finally I can get rid of gnome-nm. Anyway, certificate handling really needs to be fixed.