How to use(typing) Thai language in Editor (openSUSE 12.1 KDE)

I can not use thai font

Welcome to the forums. Go to System settings>Input>Keyboard>Layout … then Add the Thai layout. After that an flag icon will appear in the systray showing which keyboard is activated. Click on this to cycle through the keyboard layouts you have activated (you are allowed up to four).

I assume you have a Thai font installed systemwide.

It works!, thanks a lot.