How To use Persian Language support in openSUSE12.1 x86/64

As I remember in openSUSE 11 I just needed to go to yast->Language setting under system section to use full features of Persian (Farsi) language.
here in 12.1, I tried this but there is no Persian(Farsi) language in secondary language list!

Since I wasn’t using openSUSE for some while, I would appreciate hints.

Did you install Farsi? (YaST > Software > Software managment and then the View tab > Languages, search for Persian (fa) and install that. Then you will at least have the Persian translations of many applications.

Assuming you are using KDE, try system settings>input devices>keyboard>layouts>add and select Iran which appears between E and F and so I suspect supports Farsi.

that didn’t work…
this way I’ll just get some Persian interface for some application. I needed to do what john_hudson said
however thanks

Dear John
Yes I am using KDE and I also needed to add a keyboard layout
But I had 2 difficulties:

  1. I couldn’t find “system settings>input devices>keyboard>layouts”… I just searched keyboard on launcher… if you will show me the direct path I’ll be grateful
  2. Yes “Iran” (my birth country) supports Persian language. But in layouts I needed to add Persian(not Iran)

thank u very much

You are welcome. With languages there are allways several things that must work. And even if someone explains rather clear what his problem is, he may still mean one of the others or needs one of them solved too. I mention:

  • Fonts for showing output on screen and prints.
  • Internal presentaion (I consider that solved as Linux nowadays uses Unicode).
  • Translations of texts in applications (menus, buttons, help text, …)
  • Means of input (including keyboard layouts).

Apperently you were after the last and that seems now be solved.

BTW I do not think (but I am not sure) that there is a shortcut inti the KDE keyborad configs. But IIRC (but it is a long time ago I had more then one keyboard layout defined in my KDE), there must now be an icon in the panel where you can change easy between the two (or more) layouts you configured as to be used.

Sorry, I may have confused you by using the KDE4.6 terminology - it has changed with different versions of KDE - but I am talking about the option for configuring KDE which normally appears in the list when you click on the Gecko.

If you move the cursor over the different options, a submenu should appear and ‘keyboard’ or ‘layout’ in tthe submenu should indicate the correct icon to select.

As I mentioned ‘Iran’ appears between E and F in the list - which is mostly alphabetical; so I assume Iran in that position stands forr Farsi.

I do understand you. The wording/naming of the menus and in the list is not that important. But IIRC you can add added a keyboard layout to a list, which list will after that be directly accessable through an icon in panel at lower right. Is that not the case? Or is that the case and do I misunderstand what you want?

That is what I meant to convey but KDE appears to have changed the hierarchy/nomenclature yet again - as you say, once you have localed the tab which allows you to add a new layout, it then becomes available in the systray. The problem appears to be finding the tab to make the initial selection.

Yes, the KDE configuration tool is not one of my favorites either.

Hi, I have this problem too, i finded the “System Keyboard Layout” , but this havent any thing to add new language.

Any one to answer ??

Please check if you’ve got the persian equivalents of this packages installed :
SUSE Paste

Hmm ??:::\

My advice would be to start a fresh thread with a good, telling title and an extensive explanation on what your problem is. Not many people will come back to a thread like this after so many days. Especialy not after the OP has more or less said: thank you.
[FONT=DejaVu Sans]خراحاڧظ[/FONT]

On 2012-06-05 09:56, emaadghorbani wrote:
> Hmm ??:::\

I’m sorry, but I can not help. I don’t understand completely the problem, I
don’t use Persian.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)