How to use KDE 4.4

I don’t know if this functionality just isn’t working right or if I just can’t figure it out. Under Desktop Activity Setting > Mouse Actions, I can’t make heads or tails of how to change the mouse behavior for plasma.

The default for vertical scroll is switch desktops. How do you get it to zoom in and out?

Systemsettings - Desktop - Effects - All Effects. You will see a list of all desktop effects. Look for the one that’s invoking the desktop switching, change it’s shortcut to something unused. Then look for the active zoom effect and set it’s shortcut to the appropriate value.

This isn’t controlled by Desktop Effects. I’m talking about the control of the plasma desktop which is:

right click desktop > Desktop Activity settings > Mouse Actions. Either changes to these settings aren’t working right or I’m not understanding/doing it wrong. I want to change the scroll wheel to control zooming in and out.

Hold down Ctrl and scroll the wheel

I’m using the globe desktop with satellite view. With 4.3.4, scrolling up and down would cause the earth to zoom in and out. With 4.4, this isn’t working.

I did manage to get it to zoom out, which resulted in the satellite view shrinking to one quarter of the screen, while the rest of the desktop was gray and white squares. A desktop settings plasmoid also got added with a red X and a configure icon. When I clicked the red X, my desktop was replaced with the default openSUSE wallpaper.

Clearly this isn’t working right. If anyone can get the zoom out/in feature working with the globe desktop, please let me know.

It’s working fine here with 4.3.81 (KDE 4.3.81 (KDE 4.4 >= 20091204)) “release 2”

Make sure you don’t have anything set as the vertical scroller as the globe wallpaper automatically has that functionality.

Take Care,


Tonight I turned on my computer and where I had 4 entries in Mouse actions, I now had only one. And zoom in and out is working. I didn’t do anything. No updates, no nothing but now it works.

Thanks for the replies.