How to use a certificate to get internet connection

I’m trying to figure out how to enable a certificate given my internet provider to get internet connection on my opensuse 64-bit (kde 4.3)

I made a confige file for wpa_supplicant under /etc/ like this:

baris@linux-sff7:~> cat  /etc/wpa_supplicant.conf
key_mgmt=WPA-EAP IEEE8021X

As you realize at the line I showed the certificate in this way:


When I run the wpa_supplicant I get connection and the output is:

linux-sff7:/home/baris #  wpa_supplicant -Dwired -ieth0 -c/etc/wpa_supplicant.conf
Associated with 01:80:c2:00:00:03
CTRL-EVENT-EAP-STARTED EAP authentication started
CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
OpenSSL: tls_connection_handshake - Failed to read possible Application Data error:00000000:lib(0):func(0):reason(0)
CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully

I did this via wpa_supplicant because yast’s network manager doesn’t offer such a certificate thing and at the kde’s networkmanager I failed to get connection. But how can I add this to boot level to start it as a service on every boot instead of doing it at the console after I logged in the system? I tried to add this line “wpa_supplicant -Dwired -ieth0 -c/etc/wpa_supplicant.conf” in /etc/init.d/boot.local but after run the command it doesn’t continue and wait until I press CTRL+C. You can also see this behavior above at the console. Thanks

Please write a script in /etc/init.d/after.local

I added -B option which allows to app run at the back:

wpa_supplicant -B -Dwired -ieth0 -c/etc/wpa_supplicant.conf

It works with this option in boot.local

Hi again,

wpa_supplicant needs restarted after every standby (suspend to ram) operation. Also it needs to rm eth0 file under /var/run/wpa_supplicant/ before restarting.
Is there a way to make it easier?