How to update /etc/filesystem ?

Hello there,
my problem is, that opensuse doesn’t seem to be able to mount NFTS filesystems, >:( such as my external hard drive, which I would really like to access.

So after a bit of research related to the error message I got trying to mount the hard drive, I found out, that I need to update /etc/filesystems.

This reduces the problem to one question:

How do I update etc/filesystem, because I could imagine, that playing around with this file might cause some serious problems, which would probably lead to the loss of the capability to mount the partitions, my actual system runs on.

Information, which might be needed:
I’m currently running opensuse 11.4 + the file /proc/filesystems could also lead to a solution

Thank you for your replies :wink:

IMHO you are correct. What is advertised as the ultimate solution to this problem in other threads is imho only a by-pass. Next update/upgrade will overwrite it, leaving you with the big question: why can’t I mount …

I still hope someone files this as a bug (maybe it is allready done in the meantime).

Waiting for the real solution (which might even be that the official version of /etc/filesystem will get edited as per the by-pass), I see no problem or thread for you to do that change. As long as you keep in mind you did it, that it might be overwritten on any future update and that you have to redo it again in that case. And try to keep an eye on the whole problem to see iff a real bugfix arrives (maybe not easy).

I was under the impression that since NTFS is supported via the userspace ntfs-3g process in conjunction with fuse, that the kernel in a sense doesn’t natively support it and therefore it doesn’t matter that it doesn’t appear in /etc/filesystems, but somebody else can confirm or deny.

See the several threads about people that dynamicaly add NTFS USB storage devices and can not get them mounted. This after last kernel update. The adding to /etc/filesystem seems to cure it.

As I do not have 11.4 running, I can not confirm/deny it, but several people reported this (at least three threads) and I tries to get at least one of them to file a bug report.

You do not update /etc/filesystems. It’s a generic configuration file where you specify the list of filesystems to probe while mounting type ‘auto’. Under openSUSE it seems to be installed by default with the package util-linux - which includes very basic tools. There is nothing wrong with editing this file (which doesn’t mean that you can write something wrong in there).

Thank you very much for those replies,
so am I right, when I state, that this happens since the last kernel update and can simply be fixed by either waiting for another kernel update or installing the package util-linux? :slight_smile:

Problem being now, that util-linux is already installed (as you guys mentioned), so could you please post how to add the NFTS format to the /etc/filesystems file? (or post a link to a previous thread, which already contains the solution)

Or am I left with waiting for another kernel update? :frowning:


No. You shouldn’t worry about this file. util-linux is always installed as it contains essential tools (like fdisk). /etc/filesystems had to be shipped with something, so it is in this package in openSUSE. Fedora put it is in the package setup with a bunch of default config files, like /etc/services, /etc/profile, etc. /etc/filesystems is not the problem. It could even provide a solution - as we have seen in other threads.

Could you post a link to such a thread, which provides the solution or even just describe how to fix the problem?

That would be great

Edit /etc/filesystems and insert the line “ntfs” before (or after) vfat.

kdesu /usr/bin/kwrite /etc/filesystems

Thanks, that’s great, i will try it out and tell you if it works. Do you have to reboot after making the changes to the file?

This might be a stupid question, but I thought it is nfts and not ntfs you have to add, or just both, depending on the filesystem you want to make accessible?
I just don’t want to do anything wrong.

I do not think a reboot is needed. When it does not work as expected, try a reboot first before coming back here :wink:

And again, this is a bypass. Nobody knows if it is repaired in the next kernel or the next version of util-linux. We have to wait for that.

EDIT: it is NTFS (New Technology File System) and you shouldadd the lower case version of that: ntfs.

It works great by pasting ntfs (as you mentioned and not nfts, as I suggested).lol!lol!lol!
Just awesome. You did me a really huge favour.

Note: A REBOOT IS NOT NECESSARY (you got that right as well, but I just wanted to mention it out of experience)

Here’s just one last question for problems in the future:
Can I just paste any type of filesystem in there and it works from that point on???

You could but it shouldn’t be necessary. Which other filesystems do you have in mind?
I you want to learn more about /etc/filesystems usage, type man mount and scroll down to the description of the option -t --type.

Fat32, so do I just paste fat32 in that section?

(By the way I assume, that kdewriter is something like nano)

Fat32 is vfat and is already there.

oh, ok that’s great, so you really helped me, thanks :slight_smile:
(no further questions, everything solved!!!)

Out of curiosity, ntfs-3g works for mounting only internal hdd? I’d be really glad to know.

Don’t think so. IMHO there is realy not difference between “internal”" and “external” disks. Or do you think the computer can see if the disk is inside or outside of the box?

Thanks for replying.
So in this case 13X couldn’t use it to mount the external hdd because of the bug that asked him to update his ‘/etc/filesystem’?