How to uninstall flatpak version of Firefox?

Folks:

Recently had issues with jerky video playback and had a couple of threads on it. The first effort involved adding flatpak repo and then installing Firefox, which did improve the problem a bit, but not entirely. I then followed the “add opi” suggestion and that did resolve the problem.

So, now I have two versions of Firefox showing in my >internet directory . . . the one named “Firefox Web browser” seems to be the flatpak item, and I have “Firefox” . . . which seems to be the system browser that is working better.

I searched YaSt for both terms and both names seem to show the same package, so it doesn’t seem like I can remove FWB via YaSt . . . .

I then found the flatpak wiki, since I think I ran “flatpak install MozillaFirefox” to install it, I tried to run:

~> flatpak uninstall MozillaFirefox
error: No installed refs found for ‘MozillaFirefox’

And that seemed to error out?

I did right-click on the WB icon and it showed “hide application” . . . which might be a simple solution, but no reason to keep it around . . . .

@non_space did it install as your user? You need to use flatpak list to see what is present.

1 Like

It is

flatpak uninstall org.mozilla.firefox

But as Malcolm pointed out, you can list all your installed Flatpaks via the list command…there you can see the correct application ID.

There is also the really extensive and good flatpak documentation:

@malcolmlewis

Yes, installed as my user . . .

@hui

OK, that did get it done, thanks for that. One of my questions is, if I installed it with “flatpak install MozillaFirefox” . . . why didn’t it uninstall that way, but by what shows up in the “flatpak list” data ???

~> flatpak list
Name           Application ID                Version  Branch      Installation
Freedesktop P… org.freedesktop.Platform      23.08.19 23.08       user
Mesa           …edesktop.Platform.GL.default 24.0.7   23.08       user
Mesa (Extra)   …edesktop.Platform.GL.default 24.0.7   23.08-extra user
openh264       …reedesktop.Platform.openh264 2.1.0    2.2.0       user
Firefox        org.mozilla.firefox           126.0.1  stable      user
2:~> flatpak uninstall org.mozilla.firefox


        ID                                 Branch        Op
 1. [-] org.mozilla.firefox                stable        r
 2. [-] org.mozilla.firefox.Locale         stable        r

Uninstall complete.

I just ran a zypper dup before this, wondering whether the dreaded “mesa” problem was going to mess with my GUI . . . no problems with it . . . bunch of dracut lines. Then I see in the flatpak data that “mesa” is mentioned . . . .

Might remove the flatpak repo, since for the most part not using too much from it?? Trying to “minimize my force field” keep it to the basics . . . .

You’re running Leap (?) If yes, you should run

#   zypper up

… and not “dup” (as one would do when running TW or during a Leap Beta).

Thanks for the reminder. For the most part I try to run “devel” or “alpha/beta” or rolling systems . . . so I can keep running “dup” . . . . This is the first time in awhile that Leap hasn’t had a next level option to jump to . . . so yes, the prosaic 'up" will have to be used . . . . . . .

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.