How to turn on better fonts antialiasing for KDE4

Hi All!

I am using SUSE 11.1 and KDE4 4.3.1 from build service repositories. Also I recompiled FreeType2 (using srcrpm and build) to enable subpixel antialiasing. In KDE settings antialiasing is enabled, including subpixel. All menus and buttons looks great, but still KWrite’s text area and KHTML rendering looks ugly when comparing to what I had with 11.0 with default KDE3 installation.

Tell me please is there any way to enable something in fonts.conf or freetype1.spec or freetype2.spec to enable better antialiasing for MS fonts (like Arial and Consolas) and DejaVu Sans Mono in KWrite editing area.

Links to build instructions and fonts.conf options are appreciated.

PS: my Arial looks like antialiasing is completely off, but Consolas looks like File:Consolas-programming-2.png - Wikipedia, the free encyclopedia this one.

This is my setting:](

it rocks at this and FYI, is way better than in Vista

caf, thanx for you reply.

I have the same settings but Medium instead of “Full”. I don’t know why but “Full” on my system is almost the same as “Minimum”, while “Medium” looks really great.

Also, monospaced on your screenshot is a bit ugly as for me. And my fonts in all KDE parts (buttons, menus, labels, …) are very pretty, but ugly in KWrite and KHTML.

I hope you have got your solutions. But here is one link which made fonts look great in my openSUSE 11.2, KDE 4.3.5 system… Font smoothing in OpenSUSE 11.2 | We love Linux !. Just in case someone comes searching to this thread like me :slight_smile:

Nevermind, I didn’t realize the date of the original post !

Nevertheless, thanks to your reply I saw Caf4926’s post; I’m now looking at the nicest fonts I’ve ever had.

Same here…one of the first things I do after a KDE install

Font settings are very subjective, especially the anti-aliasing. I find Hinting: Full far too soft and blurry, and always choose “Slight”.

Yes they are… I used to disable anti-aliasing before because I liked sharp fonts. But I have started loving anti-aliasing now.

I have some very specific subpixel patches in my OBS repo at :- Index of /repositories/home:/anshuljain/openSUSE_11.2. It will upgrade your fontconfig, cairo and freetype packages from the stock Opensuse-subpixel disabled ones to LCD/Ubuntu patched RPMs. I have managed to achieve a consistent look with Vista fonts (Calibri and Consolas) using the packages in the repo above.

My ideal combination is Calibri fonts size 10 and consolas size 9. You may have to add a .Xresources file in your /home directory with the following contents:-

Xft.lcdfilter: lcddefault
Xft.hintstyle: hintslight

A screenshot is at:-](

Hope this works for you.


I have distinct dislike for windows fonts. And I booted W7 yesterdayas part of some experimentation I am doing. I noticed the fonts there were not as clear as in SUSE. I tried changing them from default but it didn’t seem to make a scrap of difference.
Thank heavens for openSUSE.

I admit to having windows fonts added and when they are the look is better, though I’m not actually using any windows fonts. Anyone able to explain that?

If you haven’t noticed the link I had given had link to your rpm only… :slight_smile: I am using these fonts and just loving it. Thank You again:)