How to turn off screenlocking in KDE4.2, openSuSE 11.1

since I installed KDE 4.2 (from KDE4:/Factory:/Desktop/openSUSE_11.1) on my 11.1 system I have a strange problem. Everytime I do not do anything for a while (perhaps 30min) my screen is beeing locked. I turned off the screensaver completely (locking was not turned on there anyway) but no change. I turned of any settings that could cause a screenlocking in kpowersave and but again no change. I exited kpowersave but still no change.

When my screen is locked I can always see a process /usr/lib/kde4/libexec/krunner_lock --forcelock thats running. But who the hell does start this process?

In KDE 4.1.3 that came with openSuSE 11.1 this problem did not exist.

Any ideas?

Kpowersave doesn’t define the settings in KDE4. They only work in KDE3.

Open System Settings (Personal Settings) from the Favorites list in the Kickoff menu.
Then open Power Management in the Advanced Tab.
Check the settings on your the profile you are using.

More than likely it is set to lock the monitor after x amount of time.

Thanks for the tip. Yes there a lock screen option was set. I simply was unable to find it. Somehow I think there are to many places that control the display: The display settings for screensaver, then the display energy management settings in the display section and the Powermanagement settings in the advanced tab. I missed the last one.

Thank you very much