how to turn off nvidia graphic card

please help me to use optimus technology!
i tried to install bumble bee .but i’m not succeed
there is no usefull training for it
i have searched a lot but i did not get a reasonable answer

-acer 5755g
-openSUSE 12.3

i can’t access to nvidia site to download driver!! why? cuse Bll s*it Boycott:X
*i can’t speak english as well
*why IRAN is not in register country list??:expressionless:
*my name in persian : شهاب : shahab
*thanks you

  • :kiss:

I can’t help you with bumblebee as I have absolutely no experience with that.

But maybe this could help you:
Smithfarm - the Brain: openSUSE 12.3: How to install ‘bumblebee’ for NVIDIA Optimus VGA

There’s no need to download anything from NVIDIA if you follow that…

hey thanks
i see that before but i can’t access this site.
sorry but please write that training here for me

OK, here you are:

Installation Procedure

  1. This procedure will install the proprietary NVIDIA driver and Bumblebee. To begin with, make sure I have the right version of openSUSE installed:

cat /etc/SuSE-release

openSUSE 12.3 (x86_64)
VERSION = 12.3
CODENAME = Dartmouth

  1. Also make sure I haven’t done any weird, non-standard things to the installation. Check.
  2. And make sure to remove all packages and repositories
    relating to any previous installation of proprietary NVidia driver, Bumblebee, etc.
  3. Make sure I have the Kernel Development Pattern installed (Yast -> Software Management)
  4. Make sure my user account is a member of the bumblebee
    and video groups:

groupadd bumblebee

groupadd: group ‘bumblebee’ already exists

groupadd video

groupadd: group ‘video’ already exists

usermod -a -G bumblebee,video smithfarm

For more information on adding users to groups, see the “openSUSE: Add user to group”]( blog entry on this site.

  1. Reboot just to be sure. Check.
  2. As my user account, check to make sure I am a member of the video
    and bumblebee groups:
    smithfarm@machine:~> groups
    users wheel video vboxusers bumblebee
  3. Add Overman79’s repository

zypper ar Index of /repositories/home:/Overman79:/Laptop/openSUSE_12.3 Overman79

  1. Install dkms, dkms-nvidia (proprietary NVIDIA driver), and dkms-bbswitch packages (downloading the proprietary NVIDIA driver in particular may take an excruciatingly long time, and there’s no progress bar, so I have to be patient here):

zypper in dkms

zypper in dkms-nvidia

zypper in dkms-bbswitch

  1. Install the remaining packages from Overman79’s repository:

zypper in bumblebee primus x11-video-nvidia

  1. Enable the dkms and bumblebee services:

systemctl enable dkms

systemctl enable bumblebeed

  1. Reboot and pray
  2. Try glxspheres:
    smithfarm@wilbur:~> primusrun glxspheres
    Polygons in scene: 62464
    Visual ID of window: 0xcd
    Context is Direct
    OpenGL Renderer: NVS 5200M/PCIe/SSE2
    61.096760 frames/sec - 66.138465 Mpixels/sec
    59.909029 frames/sec - 64.852722 Mpixels/sec
    59.904287 frames/sec - 64.847589 Mpixels/sec
    59.902248 frames/sec - 64.845382 Mpixels/sec
    smithfarm@wilbur:~> optirun glxspheres
    Polygons in scene: 62464
    Visual ID of window: 0x21
    Context is Direct
    OpenGL Renderer: NVS 5200M/PCIe/SSE2
    149.925632 frames/sec - 162.297496 Mpixels/sec
    162.674810 frames/sec - 176.098735 Mpixels/sec
    161.700929 frames/sec - 175.044490 Mpixels/sec
    161.484454 frames/sec - 174.810151 Mpixels/sec
    If you were wondering why primusrun gets poorer performance (I was), here’s an answer kindly provided by etam1024 – reproduced here with thanks!Because app running with primusrun is synced with vblank. If your monitor has refresh rate 60 Hz, then application will generate no more than 60 fps. There’s no need to have more fps, because monitor will not display them anyway.

Optirun does not sync with vblank, so app generates as much fps as possible. (again: doing more than monitors refresh rate, is just a waste of power).


  1. The remaining instructions are for disabling Optimus completely (to save power, run cooler, etc.)

Remove nvidia module:

rmmod nvidia

lsmod | grep nvidia

  1. Turn off discrete graphics:

tee /proc/acpi/bbswitch <<<OFF


  1. Configure modules:

cd /etc/modprobe.d

ls nvidia


cat 50-nvidia.conf

blacklist nvidia

ls bbswitch


cat 50-bbswitch.conf

options bbswitch load_state=0 unload_state=0

  1. Configure initrd by editing /etc/sysconfig/kernel and removing all mentions of ‘nvidia’:

vim /etc/sysconfig/kernel

grep nvidia /etc/sysconfig/kernel

  1. Make a new initrd:


  1. Reboot and pray
  2. Verify that discrete graphics is OFF:
    smithfarm@machine:~> optirun --status
    Bumblebee status: Ready (3.1). X inactive. Discrete video card is off.

On 2013-07-29 16:06, IranianBoy wrote:
> hey thanks
> i see that before but i can’t access this site.
> sorry but please write that training here for me

You will have to use TOR.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

thank you so much wolfi323

is it a problem?
number 9

zypper in dkms
Retrieving repository 'openSUSE-12.3-Update' metadata ....................[done]
Building repository 'openSUSE-12.3-Update' cache .........................[done]
Loading repository data...
Reading installed packages...
'dkms' not found in package names. Trying capabilities.
No provider of 'dkms' found.
Resolving package dependencies...

Nothing to do.

Strange, the package is there: Index of /repositories/home:/Overman79:/Laptop/openSUSE_12.3/noarch

Have you followed step 8 correctly?
It got a bit distorted during copy/paste, you should do this:

zypper ar Overman79

Could you please show the output of:

zypper lr -d

of course dear wolf :slight_smile:

zypper lr -d
#  | Alias                       | Name                               | Enabled | Refresh | Priority | Type     | URI                                                                                                              | Service
 1 | Overman79                   | Overman79                          | Yes     | No      |   99     | rpm-md   |                                 |        
 2 | Repository                  | Repository                         | No      | Yes     |   99     | plaindir | hd:///?device=/dev/disk/by-id/usb-UFD_2.0_Silicon-Power8G_201208SP0179070C28A198C26E69-0:0-part1&filesystem=auto |        
 3 | home:MargueriteSu           | home:MargueriteSu                  | Yes     | Yes     |   99     | rpm-md   |                                      |        
 4 | home:j-engel                | home:j-engel                       | Yes     | Yes     |   99     | rpm-md   |                                           |        
 5 | home:mkubecek:sisyphos:12.3 | home:mkubecek:sisyphos:12.3        | Yes     | Yes     |   99     | rpm-md   |                          |        
 6 | openSUSE-12.3-1.7           | openSUSE-12.3-1.7                  | No      | Yes     |   99     | yast2    | hd:///?device=/dev/disk/by-id/usb-UFD_2.0_Silicon-Power8G_201208SP0179070C28A198C26E69-0:0-part2                 |        
 7 | repo-debug                  | openSUSE-12.3-Debug                | Yes     | Yes     |   99     | yast2    |                                                   |        
 8 | repo-debug-update           | openSUSE-12.3-Update-Debug         | Yes     | Yes     |   99     | rpm-md   |                                                                  |        
 9 | repo-debug-update-non-oss   | openSUSE-12.3-Update-Debug-Non-Oss | Yes     | Yes     |   99     | rpm-md   |                                                          |        
10 | repo-non-oss                | openSUSE-12.3-Non-Oss              | Yes     | Yes     |   99     | yast2    |                                                     |        
11 | repo-oss                    | openSUSE-12.3-Oss                  | Yes     | Yes     |   99     | yast2    |                                                         |        
12 | repo-source                 | openSUSE-12.3-Source               | Yes     | Yes     |   99     | yast2    |                                                  |        
13 | repo-update                 | openSUSE-12.3-Update               | Yes     | Yes     |   99     | rpm-md   |                                                                        |        
14 | repo-update-non-oss         | openSUSE-12.3-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md   |                                                                |        
15 | utilities                   | utilities                          | Yes     | Yes     |   99     | rpm-md   |  

i do step 9 with your latest post
but line 1 and 3 , not 2 because one of my friends said to me dont enter line 2.because is not nessesery

Right, #2 is not necessary, that’s the media you installed openSUSE from. But you have the online repo anyway.

But you should enable “Refresh” for #1:

sudo zypper mr -r 1

no i mean step 9 line 2!

step 13 :

primusrun glxspheres
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

Sorry, I won’t be able tp help you anymore today.

But could you please post /var/log/Xorg.0.log?
Upload it to SUSE Paste or similar and post a link.

I will be with you again tomorrow…

ok thanks you:) see you later
SUSE Paste

Just a note, bumblebee runs a virtualserver the log is Xorg.8.log, not that I believe it matters in this case. Obviously nvidia-dkms didn’t install, you could try to install it via yast, we can get a little more information there, look especially if the file NVIDIA…run downloads. If not I’m afraid it’s because this repo downloads it directly from Nvidia. You can at least keep the rest of bumblebee to keep the Nvidia-card powered off untill we find a solution.

ohh yes it’s ok
the bumble bee is worked after 2 reboot!
thanks you wolfi my friend

optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.