How to switch to the NVIDIA dGPU in Tumbleweed?

@aronkvh OK, that looks good. So just start blender (no switcherooctl) does it see the Nvidia gpu?

I’ve tried with switcherooctl and without, neither sees the GPU

@aronkvh can you download the Blender Benchmark Launcher CLI (tarball) extract and run that, does it show the device in the list…

The benchmark does show “NVIDIA GeForce RTX 4060 Laptop GPU”

@aronkvh So, it would appear the blender install is a bit foobar… What command are you using to launch with switcherooctl?

I was trying switcherooctl launch -g 1 blender
Installed Blender from the main repo

I replaced the distro package with the Flatpak.
Now CUDA and OPTIX seems to work (except the very small cursors) - maybe a packaging issue?
Thank you for helping me get a usable setup :slight_smile:
Now I just need to figure out how to make the MUX switch and slimbook notifications work…

@aronkvh well switcherooctl is the way, GNOME has the dbus integration to just right-click on a desktop icon to select launch the dGPU. I believe it’s coming to Plasma at some point. You can always create desktop entries your wanting to use the dGPU with with switcherooctl </some/path/to_application>

@aronkvh Just switcherooctl should be enough, or you could try adding the environment variable as a test;

__GLX_VENDOR_LIBRARY_NAME=nvidia __NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only \
blender
1 Like

I can’t edit it anymore but I forgot to add:

The drivers loaded after I disabled secure boot.

1 Like

Should I complain somewhere that SDB:NVIDIA still shows the old location?

Thanks for the hint. I oversaw that the path is also mentioned in the text block and not only in the command part…adapted now.

On my phone so sorry for brevity. I see prime-select seems depreciated. I was unable to get switcharooctl to work on my laptop with NVidia. I ended up reinstalling prime-select and use prime-run and it works.

1 Like