How to switch from Nouveau to NVidia drivers?

Hi,

After installing 11.3, I realised that my graphic driver is not working as desired. I have a Compaq CQ60-430SA laptop with an NVIDIA 8200M graphics card. Earlier with 11.2, I had some proprietary NVidia drivers and my graphics were smooth.
However, I am not getting the same performance with Nouveauā€¦ :frowning:

As can be seen from the screen clipping below, the images especially in the preview mode and the icons look jarred (highlighted in red). I have no complains with the video but the images and icons do look shabby at times and therefore I want to switch over to the proprietary NVidia drivers.
http://i34.tinypic.com/14v5q3a.jpg
http://i33.tinypic.com/4qiva.jpg
http://i37.tinypic.com/28s585v.jpg

Can somebody please guide me with the switching process? I did read the documentation below, but could not understand the processā€¦
SDB:Configuring graphics cards - openSUSE
Should I directly jump to the proprietary graphics card installation step?
SDB:Configuring graphics cards - openSUSE

Yes.

Do not forget to blacklist nouveau in the 50-blacklist.conf file with root permissions:

echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

and also donā€™t forget to disable KMS by going to **yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD **and change it to ā€œyesā€. This takes a minute or two to save once changed is submitted.

You will need to restart afterward. Then procede to install the proprietary driver.

Hi oldcpu,

Just followed your instructionsā€¦ Installed the proprietary NVidia drivers and OpenSuse 11.3 now works like a charmā€¦ :slight_smile:

Thank you so much!!! :slight_smile:

Addition:
in my case (Opensuse 11.3) adding the nvidia repository was sufficient. The nvidia driver was choosen automatically. No blacklisting of the nouveau driver was necessary.
ā€œNO_KMS_IN_INITRDā€ was also changed automatically to ā€œyesā€.

Best wishes

Michael

Good news! Glad to read it works now.