How to stop device notifier from popping up?

Hello, I’ve got one question: how can I disable pop-up window of “Avaliable devices” from popping-up time-after-time in system tray? I use OpenSuSE 13.2 KDE. Thank you for answering my question.

My idea is that it only pops-up if a new mass-storage device is connected. Is your experience different?

Yes! It is always popping-up. Yes, I always have mass storage connected (external hdd), but in previous Opensuse editions things did not go like this. Also, no matter if storage mounted or not, notifier pops up.

Unlock Widgets, then look for the small triangle (system tray icon) or adjacent region, and right click > System Tray Settings > Display > Device Notifier then uncheck > OK

Does the USB device power down then power up this is probably causing the problem. A popup every time the device restarts. In any case removing the notifier would certainly stop the popups but then you don’t get any notifications.

I don’t see that here either but it may be a power cycling problem and none of my devices power cycle.

My idea is that the OP does not want to kill the notifier, but to stop the unneeded and irritating pop-ups when the device it is already in use.

My idea is that the OP does not want to kill the notifier, but to stop the unneeded and irritating pop-ups when the device it is already in use.

		 		 	 You are right. I realy don't want to lose information about  devices connected, but to stop pop-up. It happens no matter if device is  mounted or not.

The notifier pops when a device is seen to come on line does not matter if it is mounted. It normally is not until you do something with it.

So does this (unknown) device have some sort of power saving feature that may cause it to spin down then come back if accessed??? Maybe check the specs read the manual???

It is not normal for this to happen so Isuspect that it has to do with some property of the thing that is connected.

I think the OP simply does not want to be notified about any devices, and it is possible to disable it as I mentioned above. (However, I personally think it is a useful utility.)

Did you read post #4 yet?

As the pop-up should only be a result if the system seeing the act of connection, you should check dmesg to see if the dvice realy disconnects and conneects again every time you get the pop-up. The would confirm gogalthorp’s suggestion, something wromg with the device or USB.

My problem solved when I manualy mounted device. Click in task bar “Avaliable devices” and mounted it So, next thing I have to do is to find how this to mount automaticaly, but only when it is plugged in (no system to ask me “where is your external hdd?”). Thank you all for helped me and gave me idea.