How to start the Gambas3 Application

I am sure that this is a stupid question but, here goes I installed Gambas3 with Yast on a machine running Open Suse Leap 15.2. It was over a hundred files, every thing was fine.
When I try to start the program I get a blank screen. I haven’t had any other problems with this system in fact I think its one of the best.

I did not install any of the debug files. thats what I will do next.

First tell us how you tried to start it.

I assume from a GUI menu?

Then try starting it from a terminal to see what is happening.

You also need to post the version of your Gambas3 and exactly where it is from.

The following suggests that you should install the version from the Education repository, but a more recent version is available from a private repo.


:~> The version I have is Gambas3.14.3 from the default Repository.
I will check out your suggested thread for the location of the current version


Thanks for all the help and suggestions

I started programming in basic on the TI-99/4A in 1982 then on several CBM machines a few years later I built an IMB AT compatible computer and used GW Basic. I have spent enough time playing with this program, computers are supposed to make things easier, when an application won’t even start I think it is time to dump it and move on.

Thanks again

Although I don’t use Gambas3, it looks interesting and versatile.
If there is a bug in the version from the main repository, you can always try the other one from the private repo.


My question about running Gambas3

Although I don’t use Gambas3, it looks interesting and versatile.
If there is a bug in the version from the main repository, you can always try the other one from the private repo.


I would like to thank you for the help and encouragement.
It turned out to be operator error, When I installed Gambas3 somehow one of the components was not installed completely, after trying to get it to function I traced the steps the program went through until it ran into trouble and installed that needed component.
I wish i could remember exactly which file was needed. Sometimes you just expect the computer to do all of the work for you and work flawlessly.
The version of Gambas3 on the standard Repository works fine, the ide is a pleasure to work with and. The folks who developed and maintain this put a lot of work into a very nice looking program.

To anyone using Gambas3 and experiencing the famous “gbx3: unable to find startup file” and any of the “gbr3: unable to load component” or the “Cannot load component” or “cannot find component”, here’s what works for me:

Look for the name of the component that is missing. In my case, when I run “gambas3.gambas”, it shows the following:

jasongo@localhost:~> gambas3
gbx3: unable to find startup file
jasongo@localhost:~> gambas3.gambas
ERROR: #27: Cannot load component 'gb.jit': cannot find component

** OOPS! INTERNAL ERROR. Program aborting, sorry! :-(
** Unable to find JIT._Abort() method
** ERROR: Unable to find method _Abort in class Jit. Symbol not found
** Please send a bug report to the gambas bugtracker [1] or to the gambas mailing-list [2].
** [1]
** [2]

So what I did next is to install “gambas3-gb-jit”

sudo zypper install gambas3-gb-jit

Now it loads the Gambas3 IDE perfectly. I’m using openSUSE Leap 15.4 with the Education repo.

Generally, the format of the component is gambas3-gb-NAME OF THE COMPONENT

So if the error is missing gb.image, then you just need to install gambas3-gb-image.

Another important component is gambas3-gb-dbus which is used by the tray component. In some systems this does not install as dependency so just be sure to check if this is installed in your system.

Lastly, if it does not bother you then just install every component in your development workstation. All components starts with “gambas3-gb-*” so that will cover everything said above.