How to start debugging smb problem?

I’m used to use SuSE without network problems since 9.2 or so. Now I encounter an unresolvable problem with windows shares on a home network. I have running multiple shares (data, network storage device, Knoppmyth, Xp-machines). Up to SuSE 10.3 everything went fine. Now I started with OpenSuSE (both Gnome and KDE 4 on Pentium based and ADM based machines, both 32 bits) installed on an external USB drive. Installations were compared to Ubuntu 8.04 LTS.
The only problem is to browse and read/write shares on the home network. Firewalls are down (on this side of the gateway). I’ve studies the website of swedna (Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE). Multiple post were found but solution. My problem is that I don’t know were to start debugging this. Therefor I submit some smptoms:
1)a) Samba browsing (using Dolphin) said: no connection to host using resolve://smb-resolve
1)b) Samba browsing with Ubuntu 8.04 works fine using standard file system browsers
2) I’ve tried to configure network (samba server and client) using the configurations tool of KDE 4: this crashes
3) mounting remote shares using mount command manually works fine
4) adding lines to fstab (using cifs mounts) works also fine
5)a) fusesmb fails mouning the network
5)b) Ubuntu 8.04: fusesmb works fine with same configuration as 5)a)
6) automount (autofs v 5.0.3) fails to mount samba shares
6) b) automount (Ubuntu 8.04, v 4.1.4.) mounts just fine using the same auto.master and auto.‘share’ files

So I’m lost, don’t know were to start debugging. Possible multible sources of error.

Can somebody advice how to start debugging this problem?

Thanks, F.

Samba is working do a degree if you can mount the cifs shares as you boot.
I’ve never used smbfs – but maybe if you can get network browsing organised better, maybe smbfs would follow.
Dolphin is saying it can’t find a a network.
Your list might reduce once name resolution is fixed. So can you post the Samba configuration file so we can see how it’s set up?
That’s the file /etc/samba/smb.conf. You cann see it with this command:

cat /etc/samba/smb.conf


post your smb.conf post the command you use to mount and tell us what kind of partitions are on your usb drive.

Hi, I’ll try to answer the questions

Forgot some important details:

I’m using openSuSE 11, KDE desktop on Pentium 4 system and Gnome desktop on AMD system. All firewalls behind the router are disabled. I have two workgroups in the home-network, one NAS (Synology) and one machine with KnoppMyth R16 intalled (debian based, few years old). I do not have smb.conf files of the NAS.

cat /etc/samba/smb/conf

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2008-06-06

workgroup = THUIS
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = No
security = user
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
netbios name = USBLIN
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST


This is the .conf file on the machine that wants to connect to the /Server/some-share


I can mount share using the following command:
sudo mount -t cifs -o username=thisuser,password=hidden,uid=me,gid=users // /media/network

I’ve tried smbclient for the first time today, is just works fine!

I’ve tried to use Nautilus on the AMD machine: Nautilus shows the servernames/workgroups (have two workgroups in the homenetwork), but the shares are hidden. After typing the name of the share in the location bar I will be asked for username, password and workgroup. After that all folders on the share are visible.

On the KDE 4 machine (Pentium system) I can enter
smb:// and Dolphin / Konqueror askes for username and password. On this system I’m able to actually read files (media files, using VLC) but on the AMD system VLC cannnot read mediafiles! Strange!!

For the time being I have added some entries in /etc/fstab, but sometimes mounting doesn’t work. Adding @reboot mount -a options in cron results in endless shutdown times…

The filesystem on the USB disk is:
ntfs (so fuse is loaded at boot time)

Up to aufofs 4.1.4 (in Suse 10.3 and Ubuntu 8.04) I’ve had no networking problems. With autofs 5.0.3 things have become complicated. Maybe I’ve some wrong configurations? Thanks for looking at this problem.


I can’t see anything major. Smbclient works in nmae mode. KDE4 is problematic for Samba. But Gnome should work. I can only suggest to try this version for the [global] paragraph, backing up the old one first:

workgroup = THUIS
netbios name = USBLIN
name resolve order = bcast host lmhosts wins
server string = “”
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
use client driver = yes
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
usershare allow guests = Yes
usershare max shares = 100
usershare owner only = False

I’ve not used autofs or fusesmb – only Konqueror & Nautilus and (now a days) cifs mounts

Thanks, I will give it a try. I updated to KDE 4.1, noticed one change: smb4k is now (partially, one workgroup) working!

I wonder if someone can tell whether the samba suite is compiled with the option --automount (or something similar) in opensuse 11. I’ve found that this option can be disabled when building samba from source. But it makes no sence to disable this feature, so I don’t think that it is disabled…

Thanks again.


KDE4 is at best intermittant for Samba. It’s experimental, not more than experimantal. Perhaps your 4.0 install → now 4.1 has contaminated Gnome.

The only way I can see to resolve this is to reinstall with pure Gnome, get that working Samba and then add 4.0, see what that does, then upgrade to 4.1, see how that does. Any other KDE4 mix, including yours, is impossible to analyse logically because it’s simply very buggy.

Hi swerdna,
I switched to the AMD machine (Gnome install opensuse 11). Network browsing using Nautilus is working now. Autofs mounts flawless, but any triggerd mount as prepared by the autofs system (using Xterm and cd to the mount) will trigger Nautilus to open and show the filesystem on the share. I can live with that. I’ve not tested fusesmb yet. Still puzzled, the initial install of Gnome was not working with respect to network browsing and autofs.

Next I will uninstall fusesmb and smb4k (is that part of the KDE suite???) and test again.



smb4k is kde, not installed by default in Suse 11.0
fusesmb is not affiliated with a a particular Desktop Environment & not installed by default in Suse 11.0

Great that you’re getting better results!