How to start bumblebee daemon on boot?

Hi All,

I’ve followed Russian guide on to install bumblebee and nvidia drivers on my Dell L702x. I did use updated repos so I’ve installed bumblebee 3.0.1 from Index of /repositories/home:/Overman79/openSUSE_12.2 and latest nvidia drivers from Index of /repositories/home:/Bumblebee-Project:/nVidia:/latest/openSUSE_12.2

Bumblebee works just fine, except that every time I reboot I have to start Bumblebee Daeomon manualy by typing

sudo /usr/sbin/bumblebeed --daemon

The guide suggest that running

sudo /sbin/chkconfig bumblebeed on

will enable the service but all I get is “bumblebeed: unknown service”, if I run

sudo /sbin/chkconfig /usr/sbin/bumblebeed on

I get “/usr/sbin/bumblebeed: unknown service”.

My research points to two ways of enabling service on openSUSE:

1). use

insserv servicename

which I suspect is an old method and does nothing for me
2) user Yast–> System Services (Runlevel), but bumblebee is no on the list

There is a /usr/lib/systemd/system/bumblebeed.service file, which seem to define the service. file is owned by root with read access to everyone, but there is no script in /etc/init.d/

I’d appreciate your help in making bumblebeed start on boot

You need to use systemd;

systemctl enable bumblebeed.service
systemctl start bumblebeed.service

The first command will create the link so it will start at boot. The
second one will start it if it isn’t running.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 2 days 11:47, 3 users, load average: 0.15, 0.15, 0.14
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Thank you, that is exactly what I needed