How to show audio tag ID3 information in file manager properties?

In the past I was able to view audio tag (ID3) information in the file manager properties dialogue. I found this function useful, eg. for cleaning up ‘podcasts’ in the downloads directory. With recent openSUSE versions (using KDE Dolphin 14.12.3 and Krusader 2.4.0-beta3 with openSUSE 13.1) this is not the case.

The (somewhat outdated) Krusader manual says ‘KDEmultimedia’ is required to build Krusader with this function but perhaps this is no longer possible.

I’m just curious but I would like to know if it is possible (practical?) to show audio tag ID3 information in the file manager properties dialogue under KDE.

I suppose that applies to KDE3…

I’m just curious but I would like to know if it is possible (practical?) to show audio tag ID3 information in the file manager properties dialogue under KDE.

Yes.
And it should work out of the box actually.
The standard openSUSE kfilemetadata package contains a kfilemetadata_taglibextractor.so that should be able to read/display the ID3 tags.
It works fine here on 13.2.

Maybe you have some conflict regarding taglib? 13.1 shipped with an older version (1.8), the extractor might crash with the newer one from Packman (1.9.1) maybe?
Try to switch back taglib (the package libtag1 in particular) to the distribution’s version as a test.
You might have to ignore dependencies though, Packman’s amarok e.g. requires 1.9.1 and will crash with 1.8, the distribution’s version should work fine though.

Thanks for responding wolfi323. Good to know it’s working for you on 13.2.

I tried a vendor change / downgrade of libtag1 to 1.8 on 13.1, as suggested, with no success. The function is also not working for me on a test install of 13.2 KDE with libtag1 = 1.9.1-3.1.9 from distribution repo.

Curious, but no big problem - easy enough to work around this for the few times I use it.

Ah, I think I misunderstood you. You are talking about the properties dialog, i.e. the one that appears when you right-click on a file and select “Properties”, right?
Yes, this got removed in KDE 4.13, because it still used the old Nepomukv1 and strigi, and was quite buggy.
It was not possible to port it to Baloo because of kdelibs’ feature freeze, but it will be possible to readd it for KF5 soon when Baloo becomes a Framework.

Enable dolphin’s information side-bar (View->Side Bars->Informations) and/or “Show Tooltips” in dolphin’s “General” settings for displaying the file’s ID3 tags and hover over the files instead.
No idea about krusader though, I don’t have it installed.

PS: you can install kdelibs4 from here to get back the informations tab in the properties dialog:
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Current/openSUSE_13.1/
(I think only libkdecore4 is necessary)
And in this case you should probably install strigi from Packman for full multimedia codecs support.

Thank-you for explaining. I had suspected this may be the case.

Enable dolphin’s information side-bar (View->Side Bars->Informations) and/or “Show Tooltips” in dolphin’s “General” settings for displaying the file’s ID3 tags and hover over the files instead.

This does not work for me. I see only Type and Size information and options to add Tags and Comments.

PS: you can install kdelibs4 from here to get back the informations tab in the properties dialog:
http://download.opensuse.org/reposit…openSUSE_13.1/
(I think only libkdecore4 is necessary)
And in this case you should probably install strigi from Packman for full multimedia codecs support.

I have not attempted this but thank-you for the suggestion.

I am grateful for the time you have taken to respond to my questions and for all the good work you do on these forums. My curiosity is indeed satisfied.

It should work:

But if Baloo is enabled and you are in a folder that is to be indexed, only the informations from the index are displayed.
So try to disable Baloo as a test. Maybe the files are not indexed yet and therefore no tags are shown.
And try to right-click on the information panel and choose “Configure”. Maybe displaying the additional informations are disabled?

If that doesn’t help, I can only think of two things:

  • the possible libtag issue mentioned earlier
  • the files don’t actually have ID3 tags, or are broken somehow