How to share folder on ntfs drive in OpenSuSe in virtualbox?


Just finished installing OpenSuSe 11.2 GNOME live cd in Sun’s virtualbox software in my Win 7 host OS.

I shared 1 folder for this suse virtual machine.
How can I mount shared folder?
virtualbox has given this command > mount -t vboxsf share <share_name> but not working. in fdisk -l in suse its not showing any win folders.

Problem is I am not able to access my host using smb:// command. ping reply is also nothing. :frowning:

Any help?


VirtualBox Guest additions in OpenSUSE 11.2 - openSUSE Forums

Found above link. I fired 1st command and it seems like I need to download 98 mb dependancies for > zypper in kernel-source kernel-syms

Above link seems to be sent during beta stage. Any 1 tried using some other easier way in final version of 11.2? :slight_smile:

Prior to running the mount command did you create the directory?

sudo mkdir /windows
sudo mount -t vboxsf share /windows

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 11:57, 2 users, load average: 0.16, 0.09, 0.02
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Tried just now. It says > **mount: unknown filesystem type “vboxfs” **

also tried vboxsf same error.

Hey I found that 30 MB VBoxLinuxAdditions.iso in iso list in my virtualbox.
Now I am running >> from that iso

Error > Please install GNU compilar & it says install headers & build for your current Linux kernel. Also says install GNU make

Can I get that from OpenSuSe dvd iso? I have it with me right now.

Found gnu compiler in suse 11.2 installer dvd. Now installing it. It’s installing many dependancies of approx 600 MB. Will post further report soon :smiley:

Any 1 had sucess in mounting vmxsf drives without doing any R & D ? :expressionless: