How to setup wayland to default under kde

I tried to find it under sysconfig but I can’t find it. Any know?

Thanks in advance.

I’m not aware of a setting for that.

There’s a setting for the default Xsession and one for the default Wayland session. Those are set with the “update-alternatives” command.

Usually the desktop manager (such as SDDM) remembers your last session, and defaults to that.

SSDM doesn’t seem to save it after reboot. Is there any way to reset the cache on it?

I set it to default to default now but the same issue persists, it never saves plasma (wayland) after reboot. I don’t know what I broke and how to fix this.

For SDDM the last session is defined in /var/lib/sddm/state.conf

For example, I have

# Name of the last logged-in user. This username will be preselected/shown when the login screen shows up

# Name of the session file of the last session selected. This session will be preselected when the login screen shows up.

For Plasma (Wayland), the following entry is present…


Note if you have configured autologin, then the session defined in /etc/sddm.conf will be invoked. That can be configured by hand or via System Settings > Startup and Shutdown > Login Screen (SDDM).

1 Like