How to setting VPN PPTP in opensuse 12.2

Hi all,

How are you today? :smiley:
I’ve problem VPN connection.
I’m confused, how to setting VPN PPTP in OpenSuse 12.2.
I have provider smartfren modem and that modem not detect in my Operating System, i’m connecting with wvdial connection after that.
how to setting VPN PPTP in OpenSuse 12.2 ?
Can you help me leave from my problem?

lol!
Best Regard,

Okik Setianto

> how to setting VPN PPTP in OpenSuse 12.2 ?
> Can you help me leave from my problem?

are none of these helpful?

https://www.google.com/search?q=site%3Adoc.opensuse.org+VPN+PPTP


dd
openSUSE®, the “German Engineered Automobile” of operating systems!
http://tinyurl.com/DD-Caveat

Hi,

I’m Chinese (Chinese use VPN a lot), and I never see a problem of NM & VPN.

Here’s my personal advices

  1. VPN must be system connection and you have to use KWallet (if there’s password).

  2. You must open the port used on Firewall in YaST.

  3. if openVPN, you have to save the config with a permission root user can read.

For the detailed NM setups, please use google to read this Chinese page on zh.opensuse.org

https://zh.opensuse.org/SDB:VPN_配置#PPTP

I think you must mess something up in Advanced tab. :\

Greetings

Marguerite

Hi MargueriteSu,

Moreover My problem situated on modem connection.
I’ve modem SmartFren CE682, my modem not detect in open suse 12.2, and I search and googling for connection Smart Fren CE682 use command wvdial
it’s hard to access VPN because I’m dial connection with command “wvdial” and my modem not compatible in open suse.
Any other solution?
What that is forwarded to operating system 12.3 in launching march 2013 adverb ?
I hope now condition not occur in next operating system.
And now, please help me to solve my problem connecting VPN.

Thanks,

Can you tell us what brand/model your modem is? Is it a DSL modem? Hardware connection?

Hi Dean,
As below that is spesifikasi my modem
I’m use Smartfren CE 682.

  • CDMA 2000 1x EVDO Rev. A 800/1900 Mhz
  • Maximum Download up to 3.1Mbps & Upload up to 1.8Mbps
  • Voice Call function
  • SMS function
  • Micro SD Card
  • Plug and Play

Can you see that spesification my connection.
Just plug and play, but I use in suse operation i’m connecting with command “wvdial” i do not use my modem with enable mobile broadband in pannel
so what I do to connecting use vpn?

It is not a model I am familiar with.

Just plug and play, but I use in suse operation i’m connecting with command “wvdial” i do not use my modem with enable mobile broadband in pannel

Okay, so you are connecting with wvdial. It would be easier to get your VPN connectivity working if you were able to use the network manager (which is what I use). Are you sure you can’t configure it via the network manager? (Are you using gnome or KDE desktop?)

Does YaST>>Modems detect/configure ok?

openSUSE 12.2: Reference

so what I do to connecting use vpn?

You can configure via

YaST>>Network Devices>>DSL

Select ‘Add’, then chose ‘Point to Point Tunneling Protocol’ from ‘PPP Mode’, and enter your VPN server IP address. Follow the prompts given.

openSUSE 12.2: Reference

I’m not sure my modem it’s DSL. Any other solution?

You could try setting up via CLI instead. You’ll need to install the ‘pptp’ package first. Then you need to configure the PPTP tunnel with pptpsetup. For example

pptpsetup --create vpn_connection --server xxx.xxx.xxx.xxx --domain vpn_domain --username your-username --password your-password

where ‘vpn_connection’ is name of your connection, VPN server address is xxx.xxx.xxx.xxx, the domain may or may not be required.

Once that’s done, you’ll find the the following file created ‘/etc/ppp/peers/vpn_connection’ and your login credentials added to ‘/etc/ppp/chap-secrets’

Now, start it with

pppd call vpn_connection debug nodetach

If all went well, you’ll now have a working PPTP connection. CTRL-C to terminate.

To confirm routing table is as expected, open another terminal

route -n

I try your solution and I run pppd call name vpn_connection.
after that I gain have result such as below.

CHAP authentication failed
Connection terminated
Script pptp xxx.xxx.xxx.xxx --nolaunchpppd finished (pid 9251), status = 0x0

is there something wrong?

Are you sure that you supplied the correct login credentials when configuring with pptpsetup? (Check your config files again.) Review the manpages for ‘pptpsetup’ and ‘pppd’.