How to set the browser that opens links in Thunderbird


I’m wanting to switch to Seamonkey from Firefox for a while, to see how I like it. Currently when I click on a web link in Thunderbird, Firefox opens at the linked web page. How do I change that to Seamonkey.

I have the default Thunderbird in openSUSE 11.0 & KDE3.5(9)


Open up Thunderbird then go to ‘Edit’ > ‘Preferences’ > ‘Advanced’ > ‘Config Editor…’. Search for two strings called “” and “” and right-click on them in turn and click ‘Modify’. You can change them to whichever browser you want. If the two strings aren’t there when you search for them then just right-click in an empty space and click ‘New’ > ‘String’ then add them in turn with the name of the browser you want to use.

I cover this in my guide: openSUSE 10.3 Configuration Guide

I hope this solves your problem for you :slight_smile:

Nice tutorial on your site. I was doing IE from win2000 in VMware to look at my web pages – but greatr to see from your turorial that I can have it in Linux. I will do that next.

moving on

I added the strings + seamonkey → problem solved
Thanks very much.

BTW when I click a link in Thunderbird and there is no browser page open, it opens the page in a maximised browser. When I click a link in Thunderbird and there is already a browser page open, it does not open the browser maximised, rather it’s minimised and I have to fetrret it out and maximise it. Do you know how to force maximised opening of web pages when I click a link in Thunderbied?


And IE6 works – what a joy – no more win 2000 in VMware!
And I’ve found an IE bug in my in-page links
Great stuff

Cheers, :slight_smile:

I don’t know how to default to a focused maximised window of SeaMonkey. Perhaps look at the command line options of SeaMonkey and add the flag/option to the Thunderbird string (if it exists) - but I’m clutching at straws here, I’ve never done it myself.

Glad I could help though, :wink:

Yeah, IEs4Linux is great, :slight_smile: