How to set proxy in SUSE11.3?

I set HTTP proxy:
http://10...*:6666/
choose Use the same proxy for all protocols
fill my user name and password
An error occurred when testing:

  • Port number too large: ****** (password number)

curl: (3) Port number too large: ****** (password number)

  • About to connect() to proxy 10...* port 6666 (#0)
  • Trying 10...*… % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0connected

  • Connected to 10...* (10...*) port 6666 (#0)
    > GET NOVELL: Worldwide HTTP/1.1
    > User-Agent: curl/7.20.1 (x86_64-unknown-linux-gnu) libcurl/7.20.1 OpenSSL/1.0.0 zlib/1.2.3 libidn/1.15 libssh2/1.2.2_DEV
    > Host: NOVELL: Worldwide
    > Accept: /
    > Proxy-Connection: Keep-Alive
    >
  • HTTP 1.0, assume close after body
    < HTTP/1.0 407 Proxy Authentication Required
    < Server: squid/2.6.STABLE12-20070425
    < Date: Sun, 26 Dec 2010 09:03:51 GMT
    < Content-Type: text/html
    < Content-Length: 1700
    < Expires: Sun, 26 Dec 2010 09:03:51 GMT
    < X-Squid-Error: ERR_CACHE_ACCESS_DENIED 0
    < Proxy-Authenticate: Basic realm=“Squid proxy-caching web server”
    < X-Cache: MISS from zjupry6.zju.edu.cn
    < Via: 1.0 zjupry6.zju.edu.cn:6666 (squid/2.6.STABLE12-20070425)
    < Proxy-Connection: close
    <
    { [data not shown]

100 1700 100 1700 0 0 139k 0 --:–:-- --:–:-- --:–:-- 184k* Closing connection #0

What’s the problem?

First, you can check squid option (http_port and acl location network)

squid.conf
http_port 6666

acl my_network src 10.0.1.0/24

What kind of proxy configuration are you configuring and where?

If this is a client configuration (as it appears), I just used YAST(which configures CURL) to configure with the parameters described by your code and it succeeded without error.

Also, know that for HTTP proxying, you can also typically configure that within the web browser. In the case of Firefox, up until recently it was an “application layer” proxy, with the latest update it appears to support both application layer and the more conventional system level proxying.

HTH,
Tony