How to set php5 with apache2 ?

I’m using OpenSuse 12.1, I had installed apache and php using Yast2, from Wab and Lamp Server tab.
When I trying to open php file in browser it show me save confirmation window.

Please verify that you have “apache2-mod_php5” installed.

And “php5” should be part of the “APACHE_MODULES” line in /etc/sysconfig/apache2.

But 12.1 is out of support for 8 months already. You should really consider upgrading to a newer version.

Yes, “apache2-mod-php5” is installed, and, no it module is not connected. What file I need to connect as module?

I already told you:
Edit /etc/sysconfig/apache2, search for the “APACHE_MODULES” setting and add “php5” there if it’s not present already.
If in doubt, post /etc/sysconfig/apache2 please.

And you have to restart apache2 afterwards for the change to take effect.

Thank you! Now it’s work.

Next time, setup your server bits through Yast. In this case setting up the HTTP server would have defaulted to using php.