How to set KDE4 as default in a GNOME/KDE install?

Hi guys,

As the title states, I would appreciate information on how to make KDE4 the default environment in my system.

I run 11.1 with GNOME as the DE but later on added KDE4.2 from the factory. After having played with it and finding it stable, I would like to keep it as my main environment.

Right now, boot-up still sends me to GDM, requiring me to select ‘Others’, then KDE4.2 in Sessions before logging in. There’s also no Shutdown and Restart within KDE itself, necessitating a log-out to GDM before I can shutdown the computer.

How do I bypass this?

I think the last used DE is set to default, as you always log out via gnome you always end up logging into gnome as well.

The issue you’re describing sounds like the one I had on the unstable repositories (KDE 4.3 development), fixed it by changing back to the factory repositories (KDE 4.2).

Not sure about a shutdown command, but if you hit alt alt+f2 and type in shutdown it should find the option to for you at least.

I noticed that it remembers my last used environment. But logging back into the last used environment only seems to work if I’ve used it (KDE) in a session post-boot. Fresh boot seems to default back into GNOME for some reason.

Shutdown and restart buttons are missing, much like they would be if you launched X manually from the terminal. You’re right that I could shutdown and reboot via terminal though I was wondering if defaulting into KDE would bring the GUI buttons back.

In the yast /etc/sysconfig editor module set Desktop->Window Manager->DEFAULT_WM to kde.

I would imagine that’s how you do it, but I haven’t actually tested it.

Perfection! Thank you so much for the pointer, it does default into KDE now.