How to set GeForce GTX 970 as default video adapter

Hello forum,

I am new to Linux and have installed OpenSuse 42.3 on my home computer. The computer has a Nvidia GeForce GTX 970 graphics card and I have installed the Nvidia propriety drivers.
When I launch Steam, it reports that I only have a small amount of graphic memory so I suspect that maybe the onboard graphics adapter is being used instead of the Nvidia.

I would really appreciate any pointers about how to diagnose if the Nvidia drivers are working correctly and how to set this as the default adapter. Is the default adapter application specific or is it specified at the OS level?

Here is some system information.

> cat /etc/os-release
NAME="openSUSE Leap"
VERSION="42.3"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="42.3"
PRETTY_NAME="openSUSE Leap 42.3"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:42.3"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
> sudo lspci -nnk | grep -A3 VGA
[sudo] password for root: 
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
        Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
        Kernel modules: i915
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204 [GeForce GTX 970] [10de:13c2] (rev a1)
        Subsystem: eVga.com. Corp. Device [3842:2978]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

i don’t know if this is relevant but my monitor is connected via HDMI to my Nvidia Graphics Card so I assume that the driver is working in that respect.

Any help or suggestions would be greatly appreciated.

Nick

Further information which suggests that the GFX970 is not being used as the default adapter.

> hwinfo --gfxcard
09: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.bn_Uutzzxq8
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0412 "Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller"
  SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
  SubDevice: pci 0xd000 
  Revision: 0x06
  Memory Range: 0xf7400000-0xf77fffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw,disabled)
  IRQ: 11 (no events)
  Module Alias: "pci:v00008086d00000412sv00001458sd0000D000bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

24: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.378]
  Unique ID: VCu0.64z_lYPsVr2
  Parent ID: vSkL.3rEhpzAE0V6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GM204 [GeForce GTX 970]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x13c2 "GM204 [GeForce GTX 970]"
  SubVendor: pci 0x3842 "eVga.com. Corp."
  SubDevice: pci 0x2978 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
  IRQ: 33 (16413 events)
  Module Alias: "pci:v000010DEd000013C2sv00003842sd00002978bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)

Primary display adapter: #9

Thanks

Disable the Intel in Bios?

Hello Sauerland,

Thank you for your suggestion, I will try this tomorrow morning and report back.

Best wishes,

Nick

Hello again,

I can confirm that disabling the Intel GPU in the bios was a simple and effective solution. Now when I run hwinfo --gfxcard, I see only one adapter.


hwinfo --gfxcard
22: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.64z_lYPsVr2
  Parent ID: vSkL.3rEhpzAE0V6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GM204 [GeForce GTX 970]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x13c2 "GM204 [GeForce GTX 970]"
  SubVendor: pci 0x3842 "eVga.com. Corp."
  SubDevice: pci 0x2978 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
  IRQ: 32 (12439 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd000013C2sv00003842sd00002978bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)

Primary display adapter: #22

Unfortunately, this has not resolved my issue in steam. :frowning:

On further investigation (Steam > Settings > Display > Resolution), I see that the interface is listed as

VMware, Inc. 256MB

I think this may be the source of the poor performance. Does anyone know if there is a way to instruct steam to use the Nvidia drivers/adapter?

Nick