How to set display refresher rate to 100 Hz?


I have the following problem: My monitor (no flat screen) allows me to use a display refresher rate of 100 Hz at a solution of 1024x768 px, it consequently has to be flickerfree, and so it is under Win XP. Under Linux (opensuse 11 KDE 4.0 Desktop) there is always a slight flickering. How can I set the display refresher rate durable to 100 Hz? I tried to use Yast and changed the frequency ranges to 80, 95 and 100, but the lower limit is always resetted automatically to 74 Hz. Can you help me?

Thanks in advance,


  • emes2k,

start sax2 as root and set the correct monitor and video adapter.


Thank you for your reply!

Would you be so kind to explain this a bit more in detail? I am a linux newby and use KDE 4 Desktop.

You don’t need KDE for this. Press CTRL-ALT-F1 and log in as root.

Enter the following command :

init 3

en press enter.

Now enter the command sax2 and press enter. This will start the graphical server setup, make the necessary changes to the screen setup, do a test and save the changes (you get buttons and icons for this, you’ll find your way).

This hopefully solves your issue.

hello community,

i have the same problem - i ve played a lot with the settings but i dont get the 100 hz. its a samtron 96p monitor an a geforce 8800 gs - it worked fine for me at windowsxp for years but in kde there is only 85 hz.

hope i can find a way. some tipps?

To both of you. I am sorry to inform you but, if sax did not do the trick, then you need to modify the modelines.
I have a CRT monitor too and after eash upgrade I have the same problem. Anyways, try a google search for “modelines 100Hz” and your monitor and you will find a lot of answers.