How to set Canon ir-ADV C5030/5035 on OpenSuse 12.3

In the past i had my printer working perfectly, but after i upgraded to 12.3 it stoped working.

I had tryed every post on the internet related to CUPS, PPD files, everything you can imagine and none of these worked.

Also tryed the CQUE Version 1 driver directly from Canon, but the interface crashed everytime i tryed to set my printer.

Even tyied Google Print (with the python cloudprint module) unsuscesfully.

Today i finally solved all my problems and the solution was really easy.

1rst, be sure you have your OpenSuse 12.3 updated becasue the CQUE utility from Canon have some issues with 12.3 out of the box.

Download CQUE for Canon Europe (i used this url imageRUNNER ADVANCE C5030 then selected Linux as OS).

Install the English version 2.0.5 linux RPM (32 or 64 bits).

After it finish, open a terminal window and change to su (for the rookies, type the su command in the terminal and user your root password).

Then open the CQue GUI by typing “cque” (without the quotes obviously).

1-Go to menu File and select Create.
2-Be sure the queue type is postscript and type a name in the field “Name of the queue”.
3-Press the next button at the bottom-right.
4-In the connection type i used TCP/IP but you can use the connection type that is set in your printer (those iRADV support every connection type).
5-Press the next button at the bottom-right.
6-In the printer model press the “Browse” button and search for the “Canon iR-ADV C5030/5035 PS” model and select it. The windows open in background on my desktop.
7-Press the next button at the bottom-right.
8-You should be in the “Device options” tab, and if you have the “secured printing” enabled in your printer, scroll down and change the option.
9-Press the next button at the bottom-right.
10-In the “Print options” tab, you should enable again the “secured printing” option if you are planning to use it. Forget all about user, passwords and ids at this point.
11-Press the “Create” button and then confirm the creation with the “OK” button at bottom-left of the window.
12-At this point you should have your printer created, but WARNING! you still cannot print!
13-I dont know if necessary but i closed the cque and opened again, click on the recently created printer to select it.
14-Here goes the magic! Go to menu “Edit” and select the “Advanced” option… then click the “Accounting” button.
15-Type your user (your linux user) on the “User” field, the department id in the “User ID” field, your password on the “Password” field. Do not click the “Forced” checkboxes.
16-Now click the “Secured” button and type your secure printing password.
17-Finally click the “Update” button and save all your settings.

Now, your linux user is tied to your department ID. Print and be happy… enjoy!

PS. This also should work with every Canon printer that you have trouble with the department id thing on linux…

Well done and thanks for sharing your knowledge with configuring the Canon printer here :slight_smile: