How to save display settings: 2 screens? Is there at least 1 solution?


I have seen posts on the fact that dual screen configuration seem to be a nightmare with opensuse 11.3. As a few already mentioned, it worked all fine with 11.2 and now we are back to…

I have two screens attached to my laptop: the standard LVDS and one HDMI high res monitor. It works fine to configure it once but it is NEVER SAVED so I have to do this at EVERY boot.

Even more annoying: when the slid is closed, my laptop goes into “no display mode” (black screens) and when it tries to come back to life (opening the lid again) everything is screwed (to use a nice word).

So I would really appreciate a practical solution to this.


thanks in advance for your help.

To be a little more specific I only need to set up the two screens with:

LVDS = 1280x800
HDMI = 1900x1200, being a clone of LVDS

in a stable way. This works well by using the Display Settings, but these are not saved! Closing the lid, or even having a screen saver means that I have to REDO Display Settings everytime

thanks for any help you could provide.

Hi , first question I have is what video-card/GPU do you have?

I had a number of problems with ATI. nVidia usually worked out of the box and with added nvidia repository the install of the nvidia driver works well. (for early releases there are other ways well described in the forum)

Let’s say you run nividia GPU. Open console , login as root, type “nvidia-settings” , the gui comes up …do your config and save.

This worked for me

Cheers Otto

Thanks but I am non a Dell Latitude E4300 and this is I think a GM45 Express card.

The point is : I can easily set things up and it works well. But any time I do something which affects the Xserver (closing the lid of the laptop, having the screen saver on, etc) the set up does not come back to what it was but just gets nuts and provide me with a stupid setting (when it works at all).

So I cannot SAVE any set up and I have to reboot the Xserver quite a number of times per day. This is crazy!