How to save alsamixer settings

I’ve searched the sound threads, but haven’t found a solution. OpenSUSE 11.2 64, Audigy 4 sound card, analog stereo speakers. There is no sound at startup, I have to use alsamixer and disable the “S/PDIF Optical Raw” setting, then sound works fine for the rest of my session. How do I save this? I’ve tried alsactl store as root, but it doesn’t save it. Everytime I reboot, I have to go through this again. I had this same problem in Ubuntu, but making the correct setting in alsamixer once sured it.

If after a week or so you get no reply on this, raise a bug report on openSUSE. There is guidance here: Submitting Bug Reports - openSUSE

Raise the bug report against a 64-bit openSUSE-11.2 on component “sound”. Please run the script:

/usr/sbin/ --no-upload

and attach the file /tmp/alsa-info.txt created by that script to the bug report.

The bug report will come to the attention of the SuSE-GmbH sound packager who is also an alsa developer, and if there is a problem with alsamixer in saving settings, he is the best person to address it.

Note with the holiday season fast approaching, response to a bug report could be slow.

Very good, thank you. I’ll run that today. I am seriously considering performing a clean install with OpenSUSE 32 as the amount of applications available for 64 seems limited.

I’m not aware of any major difference between the number of applications for 64-bit differing from 32-bit.

In fact my experience now is most developers tend to have 64-bit PCs and 64-bit now tends to have the same or superior behaviour to 32-bit. Its only when one is referning to legacy/no-longer-supported apps does one encounter 32-bit apps with no 64-bit equivalent.

I’ve noticed a few simple things, like MPlayer, claim there are missing dependencies for 64 bit. At least flashplayer has a 64 bit version now. I could be wrong, I’ll spend some more time with it.

That never happens if one keeps their repositories limited to OSS, Non-OSS, Update and Packman. I’ve also seen 32-bit users report this when they went hog wild adding every repository under the sun.

Most developers, and indeed, most packagers, now use 64-bit and one is more likely to have problems here under 32-bit than 64-bit.

For example, .wma files will not play under 32-bit MPlayer but they will play under 64-bit MPlayer.

Yes, flash-player which is packaged not by the openSUSE community has had problems in the past with 64-bit, and it still is more difficult now than 32-bit to get running properly (as some 64-bit users still report more problems than 32-bit users report with flash player). But in the overall scheme of 32-bit vs 64-bit, I now see 64-bit as having the compatiblity edge.

Other than the nVidia repository, that is all I have. When I try to install MPlayer 64, it says nothing provides 64 bit, I also have trouble loading anything that needs python. It’s only day two, I’ll work through it. There is nothing I need absolutely, but I would like a few DVD authoring tools and multimedia players.:slight_smile:

I do not get this on a 64-bit openSUSE. Typically this ONLY happens when repositories are not setup correctly or when the packagers have made a mistake. Since I do not see this, I do not think this to be a packager problem.

Please provide the output of:

zypper lr -d

It looks to me that that you have an openSUSE-11.1 repos by mistake in an openSUSE-11.2 installation.

Or you are mistakenly trying to install an MPlayer packaged for 11.1 on 11.2.

I don’t know which but it looks strongly like your PCs repositories are messed up.

You were right on the money, sir. Thank you! Fixed the bad repositories to 11.2 and everything is installable now. Now, back to the sound issue…

Thank you.

Having same prob saving settings with 32bit sys…
repos look okay…

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Mozilla | Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
2 | NVIDIA_Repository_1 | NVIDIA Repository | Yes | Yes | 99 | rpm-md | |
3 | Packman | Packman | Yes | Yes | 99 | rpm-md | Index of /suse/11.2 |
4 | Update | Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
5 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |

uname -r

Iv’e tried # alsactl store …it doesnt stick…

IMHO unless one has the identical hardware, its always best to start a new thread.

Note PCM is dynamic, and its setting (volume levels) will change dependent on the application.

Update, after playing around with everything, I disabled Pulseaudio via YAST and I now have sound working everytime. Doesn’t help you if you need Pulse, but maybe this will help someone.