How to run Windows programs

I’d appreciate what I need to do to run Windows programs.


You may be able to run the program in wine:

wine *program.exe*

To do that you obviously need to install wine:

sudo zypper in wine


OK. Installed wine. The Windows program I want to run is a setup.exe file to install the program. I get this error

wine could not load L"C:\Windows\System32\setup.exe"

I created a Windows\System32 folder in root and copied the program there. Any ideas how to overcome this error?

What program are you trying to install/ run?
As for wine, the openSUSE package of it is kinda borked as it creates no menu entries so I suggest for new users is to install playonlinux instead.
It creates both menu entries and makes life a little easier.

stubble wrote:

> OK. Installed wine. The Windows program I want to run is a setup.exe
> file to install the program. I get this error
> wine could not load L"C:\Windows\System32\setup.exe"
> I created a Windows\System32 folder in root and copied the program
> there. Any ideas how to overcome this error?

When you are running wine, it assumes the presence of a C: drive. On
initialization, wine should create a (hidden) folder .wine in your home
directory. In that folder are a couple of folders (dosdevices and
drive_c). The drive_c folder is the image that wine uses for its’ virtual
C: drive, so that’s where the win-specific data/program is stored.

Your problem sounds a bit funny - I have no setup.exe in c:\Windows\System32
and I’ve install several apps. Setup.exe is an executable included with
the app, not the system. When I install something, I generally make the
directory containing the app’s setup.exe the current working directory
(cd …). Even that sometimes fails with complex installs like Microsoft
developers Studio - that one took some serious guess work to get totally

Will Honea

Excuse me if this seems obvious, but you are entering the wine command in the same directory as the setup.exe file, aren’t you? If Windows doesn’t find the app in the current directory, it will scan directories in the PATH environment variable, such as system32.

You should have run: wine winecfg

and to install use a terminal and do

wine ./setup.exe*

*or whatever the .exe is called

OK. There was no /home/user/.wine/ directory after I installed wine. So I created one and added the two sub-folders mentioned. I copied the setup.exe to the drive_c sub-folder and ran it from there. It was a bit of a mess. Although it did download the Wine Gecko Installer, and eventually did install. But it didn’t install to /home/user/.wine/drive_c/Program Files/. I found it here linux-rqai:~/.wine/drive_c/Program Files/. So which folder is this in? I can’t seem to find it except when browsing with Konsole Terminal Super User Mode. Haven’t yet tried to do anything serious with the program, since I cannot find where it’s located, except by using Konsole and running it from the command line. But on first glances, it appears to be working.

You didn’t install as su did you!?

I installed using “wine setup.exe”. Anyhow, I found my program files they were in /root/.wine/drive_c/Program Files/

Make sure that you run winecfg after installing wine and before doing anything else. This will allow you to set up all those Windo$ stuff (registry etc.)
Also, make sure that you remove the manually created .wine directory before doing this.

rm -fr $HOME/.wine

OK. I got everything working, as far as I can tell. Everything I’ve tried appears to be working. Te program and data files are not where I would like them, but that’s a small thing. The only problem seems to be the horrible fonts. Is there anything I can do about that?

I think the reason you got the error you mentioned earlier (the EXE not loading) was due to you being in the Home directory. I got the same error on my system when I tried to install a Windows program in the Home folder. Fortunately, moving the EXE to the Desktop folder and then using Wine worked.

I currently use only 100% native Linux apps, but there was a time when I needed to install Microsoft Office 2007 in Linux (now I only use Open Office).

The program is called “Crossover Linux” and is a supported (non-free) version of WINE with a lot of professional extras. Most of the windows programs I installed worked flawlessly.

Windows Applications Seamlessly Integrated on your Linux desktop - CrossOver Linux - CodeWeavers

So is there a way to improve the grainy fonts?

Try copying your windows fonts in to:

Copied all 458 fonts over, but still the same :frowning:

I suggest you do some research here:
WineHQ - Run Windows applications on Linux, BSD, Solaris and Mac OS X

I have a question on this, I installed Wine a few weeks ago on suse. I installed the latest version, access my windows installation fine, getting it to run wordpad and notepad is fine. I can also navigate to other windows directories using the Bash, getting there, then using wine to open the application, however if I go run a program like Adobe Audition CS2, Adobe Photoshop 7, Microsoft office 2002/xp none of these applications work, the gui loads, then it shows a windows crash error. I’ve looked around online but am not confident in how to fix this, am I doing something wrong, I have tried switching to SU before running the appz, but the same problem.



let me suggest you start trying to break the Redmond habit…we have
here free wordpad and notpad like programs (try kwrite or gedit,
depending on if you installed KDE or Gnome)…that run faster and are
much more configurable than anything you have probably seen before…

GIMP runs rings around Photoshop in WINE…Office? try OpenOffice

other things, have a look here:

sure, take your time…if you can’t live without notpad today, then
use it…but, broaden your horizons and you will see there is no need
to hang on to last century’s software (especially if it is ugly)…

and, if you must use proprietary software from near Seattle, do not
assume switching to run as root will ever solve anything (more often
than not, it will cause problems…) instead ASK before you run as

and before asking, do some self study/research at

(and, tell me please, why do so many new folks come here thinking that
running as root is the answer to their problem??)