How to revert LibreOffice back to

Thread title pretty much sums it up: I would like to revert LO to the version that was installed before today’s patches broke it.

I installed a set of patches on my desktop some of which took LibreOffice to v6.4.2.2-xxx. Now any LO components takes almost 3 minutes to launch.

I did not see these ridiculously long launch times with the v6.3.3.2 version that was in place prior to today’s patches.

The last time this happened was late last summer and it took a complete LO removal and re-installation of the LO packages from the Leap 15.1 DVD to get a working word processor again. I wound up removing those and re-installing from the repository to get the release (which was working fine).

How did you update.LO never has patches, it’s always a full version update.

Please show us your repos

zypper lr -d

A thing you could do, is use YaST Softwaremanager. Search for libreoffice, and for each libreoffice* package click on the Versions tab, select your desired version that is available, perform the downgrade, Softwaremanager again, search for libreoffice with only Name checked, right click in the package list and lock all packages.

That said, you should not have this issue.

BTW Are you on a btrfs filesystem ?

Last things first… No. Not using btrfs (so reverting to a previous snapshot wouldn’t be possible). I was looking to revert back to a previous version of LO (or anything, for that matter) when a patch session results in software misbehaving. The zypper documentation alludes to being able to specify a version “<X.Y” but I’m not sure whether that’s valid or not (I’ve certainly never tried it). I don’t see earlier versions in the repositories when using YaST so I wasn’t sure if going back to version N-1 was even possible.

Patch or full update, LO has twice in the past week experienced problems where components like oowriter were taking 2-3 minutes to launch (worst case: 10m). Both times were following software updates. The first set of updates did include the 6.4.x.x updates and the slow startup was first seen. After logging out and back in again to see if that would fix some odd behavior I encountered with the KDE panel task manager (it did), I noted that oowriter was starting in the typical time of just a few seconds. This afternoon, another notification popped up about new updates (Shees… this is happening almost as frequently as on a Tumbleweed system I have running). This set seemed like it didn’t have anything that would affect LO but that turned out to be an incorrect conclusion to draw. After allowing the patches/updates to go forward, the glacially slow oowriter startup was back. Again, I had to kill off all the work I was doing [grumble] to restart the desktop which, fortunately, fixed the slow LO startup. This time. Not sure about next time. The frequency of the Leap updates is not what I expected and having weird things happen on my desktop are not something I look forward to fixing so often.

Should I find a different means of getting periodic updates? The KDE/Plasma notifier is turning out to be a pain. On my Tumbleweed system, I have a cron job that goes out and lists the available patches/updates and emails it to me. I can then run “zypper dup” whenever I can schedule it. Is that something I can safely do with Leap? Would the zypper commandto grab and install all pending updates – i.e., “zypper dup” – be the same for Leap? I rather like running zypper by hand as I’ll see any warnings about needed reboots or application restarts that are needed as a result of the updates when the process has completed. If that’s happening on my desktop, it’s not as apparent; notifications don’t stay on the desktop forever. Setting up the updates check as a cron job I can run at the end of the week would be ideal.

Then there’s something wrong with how you did that.

Knurpht already explained what to do.

Search for LibreOffice.
Click the “Versions” tab. This shows multiple versions.
Select the version that you want.

You may have to repeat that for various LibreOffice components.

When done – after the desired version has been installed, the go back and lock those packages. You can do that with a right-click on the package names. That prevents them from being updated automatically.

As for how to update – that’s your choice. Personally, I disable the KDE update applet. I normally use Yast Online Update followed by “zypper up” (for packman packages). Actually the “zypper up” would do it all, but Yast Online Update gives a useful presentation of which bugs are fixed in a particular patch.

I’m not seeing this behaviour here.
[HR][/HR]Do you have the java-11-openjdk and java-11-openjdk-headless packages installed?

  • They’re “suggested
    ” by the “openSUSE-release-15.1” packet.

In the Extended Java Options setup, is a Java runtime environment selected and active?