How to restore openSUSE 11.4 boot loader after upgrading from Windows XP to 7?


Till yesterday i was dual booting with XP and openSUSE 11.4. Then i installed windows 7 in place of XP. Now 7 has the control of computer and I am unable to boot into openSUSE 11.4.
I’ve tried booting into installed openSUSE 11.4 (using the DVD) but failed (No error is shown; the computer just stalls there). I’ve also tried installing boot loader from 11.1 DVD (could not find any such option in the 11.4 DVD) but failed.
I need your help to either (i) guide me the way to boot into installed 11.4, or (ii) guide me the way to install boot loader from the ‘rescue system’ mode. I want to avooid re-installing 11.4 as i had it configured as per my needs.

PS: I’ve 7 64-bit and 11.4 64-bit; linux partitions are all ext4 and windows ntfs.


Re-Install Grub Quickly with Parted Magic

Great! Thank you :slight_smile:

Other option is booting you system with super grub CD, wich searh all your drives and recognice all the OS you have and let you choose wich one to boot, and then ance you’ve booted, reinstall grub with yast.