How to restore grub2 or bootloader after installing kernel-default?

I have 12.2 running on 64-bit computer. System was installed from KDE Live CD.
This morning I installed new package - virtualbox. As a dependencies it added few extra packages, including kernel-default.
Installation went smoothly. In the end YAST told me to reboot. So I did reboot.
Since then I can’t boot to my system.
It goes thru bios and then just a word “GRUB” appears on the black screen and nothing more.

How can I fix my GRUB loader?
Is it possible from KDE Live CD? Why is it that installation lacks ‘Repair installed system’?

Later I learned from /boot/boot.redme that:

Q: Kernel upgrade break my tuned bootloader settings, I want edit it manually.
A: set LOADER_TYPE=“none” in /etc/sysconfig/bootloader. Hint is used /boot/vmlinuz and /boot/initrd symlinks as files which is already point to actual kernel. WARNING after kernel upgrade you must update also configuration manually, otherwise you cannot boot.

The scariest part is the Warning.
So, how can I update configuration manually??

Yes, this can be done from the KDE Live CD.

Boot from it, then take over the installed system. This requires that you know on which partition your " / " is installed. In this example I’ll call it " /dev/sdX# " where “X” is an alpabetic, “#” a numeric character.

mount /dev/sdX# /mnt
mount --bind /dev /mnt/dev
chroot /mnt
mount /proc
mount /sys

Now you can start yast to reinstall / reconfigure the bootloader.

Why are you using LOADER_TYPE=“none”? Only experts do that to prevent the perl bootloader (meaning openSUSE) from messing up their (multi-boot) configuration.
With this setting your boot menu won’t be refreshed after a kernel update/change. This might be what just happened to you.

Btw, VirtualBox doesn’t require kernel-default.

Thanks a million. I have followed this Article - it’s almost the same what Knurpht said. Thank you. I run it from KDE Live CD. I did that. It said ok (or at least no error). Then I powered off and started system again and everything works!! Just to be sure I run thru boot-loader in Yast. Works! Great.

How can I add [SOLVED] and close this thread?

You can’t. Others might jump in with this issue and need other solutions. What you can do, is go to Advanced when replying and add “SOLVED” to the reply title. Then type a few words and post