How to Reset Sound?

First, using openSUSE 12.1 KDE, and while I know a lot about Windows, I’m a newbie on Linux. I was trying to get the sound to work in Skype, so opened Kmix. A message came up asking if I wanted the system to quit monitoring a list of sound devices. My assumption was that the OS or program knew what it was doing and these were bogus devices. So I told it to go ahead.

Now, I’m still getting sound out from the speakers, but I get no sound at all from the microphone.

I installed pavucontrol and I’m not getting anything different.

I’m assuming there’s just a .conf file somewhere that needs to be edited, but I’m at a loss.

Thanks in advance for your help.


If I understand, you are not asking how to reset sound, but rather you are asking how to RECORD sound from a microphone.

Is this an external Mic (plugged into a jack), or an external USB Mic, or an internal Mic ?

Assuming you are trying to record, please configure your system to record best you can, and then with your PC connected to the internet run the diagnostic script:


and select the UPLOAD/SHARE option, and when the script is complete, post here the website/address that is provided to you, indicating where your alsa sound configuration was uploaded to.

What application are you using to test your record capability ?

First, thanks for answering the post. I’ll end up learning all this like I did with DOS and Windows, but it’ll take awhile. It’s good to know there are others who will help out.

I ended up scrapping the original installation and reinstalling from scratch. It took awhile. :beat-up: So while my original post was to reset the system so it would recognize the sound inputs, that is a moot point.

I was trying to use the microphone in the webcam. The application was in Skype. Since wiping out the OS, I have the microphone working, but the volume is still lower than what it needs to be.

Here’s the link to the diagnostic script.
Looking at the data there, I can see why you only wanted a link and not the info posted here. I’d love to know what you look for specifically in there.

I know the microphone in the webcam can work because it works in WinXP and did in a previous installation of Linux Mint 12. (Yes, you have a convert to openSUSE. I like KDE and their support at LM has become sketchy at best.)

I’ve enabled pulseaudio and installed Pulse Audio Volume Control (pavucontrol) to adjust the microphone settings so they are at or above 100. Is there a microphone boost anymore?

Again, thanks for your help. I want to make this work since it is the only feasible way to communicate with my daughter who is working in France.


From the diagnostic script I can see a 32-bit openSUSE-12.1 running on a Gateway PC, where openSUSE has the 3.1.0-1.2-default kernel, and the 1.0.24 alsa driver and alsa utilities. The hardware audio codec of the Gateway is an ALC880. Two snd_hda_intel kernel sound module instances are loaded, likely one for your ALC880 analog sound and one for your Gateway’s HDMI.

wrt recording, lets look at the diagnostic script details:


**** List of CAPTURE Hardware Devices ****
**card 0**: Intel [HDA Intel], **device 0**: ALC880 Analog [ALC880 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 0**: Intel [HDA Intel], **device 2:** ALC880 Analog [ALC880 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

From ARECORD I can see you have two record devices: hw:0,0 and hw:0,2

While I am a believer in pulse audio’s functionality, for testing one’s basic record, I like to use the application ‘arecord’ which I believe mostly bypasses pulse audio.

For example, to record from hw:0,0, I would try the command:

arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav

where I am assuming 2-channels with ’ -c 2 ’ and in fact maybe it should be one channel ’ -c 1 ’ . Pay close attention to any error messages arecord may yield. That command with arecord will create and save the file ‘new.wav’ . To stop recording press . Then playback the new.wav file with:

aplay new.wav

To record off of device hw:0,2 the command is:

arecord -vv -f S16_LE -c 2 -D hw:0,2 new.wav

From the mixer I note this information related to recording:

**!!Amixer output**
!!-------Mixer controls for card 0 [Intel]**

Card hw:0 'Intel'/'HDA Intel at 0xff4fc000 irq 46'
  Mixer name	: 'Realtek ALC880'
**Simple mixer control 'Front Mic',0**
  Front Left: Playback 65 [100%] [30.00dB] [on]
  Front Right: Playback 65 [100%] [30.00dB] [on]
**Simple mixer control 'Mic',0**
  Front Left: Playback 65 [100%] [30.00dB] [on]
  Front Right: Playback 65 [100%] [30.00dB] [on]
**Simple mixer control 'Capture',0**
  Front Left: Capture 35 [100%] [35.00dB] [on]
  Front Right: Capture 35 [100%] [35.00dB] [on]
**Simple mixer control 'Capture',1**
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
**Simple mixer control 'Channel Mode',0**
  Items: '2ch' '6ch'
  Item0: '6ch'
**Simple mixer control 'Digital',0**
  Front Left: Capture 0 [0%] -30.00dB]
  Front Right: Capture 0 [0%] -30.00dB]
**Simple mixer control 'Input Source',0**
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Front Mic'
**Simple mixer control 'Input Source',1**
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Front Mic'

I don’t know if ‘Channel Mode’ (2ch or 6ch) is relevant for recording.

You appear to have both record devices set to record from the Front Mic (ie Input Source-0 and 1 ) , although Capture-1 is set at 0% for recording, while capture-0 is full up for capturing. There is a ‘Digital capture’ which I do not know what it is for. … Possibly an Internal Mic as opposed to an External Mic ?

Now upon booting, openSUSE will try to automatically configure your PC for the alsa sound driver. If that boot configuration is not correct, one can force specific model options to the alsa sound driver (only one at a time permitted), where the list for the ALC880 is on your hard driver in a directory: /usr/src/linux-you-kernel-version/Documentation/sound/alsa in the file HD-Audio-Models.txt. which for the ALC880 will be something like:

  3stack	3-jack in back and a headphone out
  3stack-digout	3-jack in back, a HP out and a SPDIF out
  5stack	5-jack in back, 2-jack in front
  5stack-digout	5-jack in back, 2-jack in front, a SPDIF out
  6stack	6-jack in back, 2-jack in front
  6stack-digout	6-jack with a SPDIF out
  w810		3-jack
  z71v		3-jack (HP shared SPDIF)
  asus		3-jack (ASUS Mobo)
  asus-w1v	ASUS W1V
  asus-dig	ASUS with SPDIF out
  asus-dig2	ASUS with SPDIF out (using GPIO2)
  uniwill	3-jack
  fujitsu	Fujitsu Laptops (Pi1536)
  F1734		2-jack
  lg		LG laptop (m1 express dual)
  lg-lw		LG LW20/LW25 laptop
  tcl		TCL S700
  clevo		Clevo laptops (m520G, m665n)
  medion	Medion Rim 2150
  test		for testing/debugging purpose, almost all controls can be
		adjusted.  Appearing only when compiled with
  auto		auto-config reading BIOS (default)

If one wanted to FORCE a model option (as opposed to relying on the automatic configuration of alsa) one could edit the /etc/modprobe.d/50-sound.conf file, adding a line to the START of that file. For example, if one wished to force the model option ‘auto’ one would add this line to the start of that file:

options snd-hda-intel model=auto

restart the alsa sound driver (easiest way for new users is to reboot) and test. If ‘auto’ does not work one could try the next option on the list (say ‘medion’ ) by replacing ‘auto’ with ‘medion’. Restart test. Try each one until one finds the optimal one.

Hopefully that model forcing won’t be needed for the gateway and hopefully this is just a mixer issue.

Wow! Thanks! I’m at work now, but will try this later. This is great info. I’ll print this out as well.