How to replace Ubuntu's bootloader with OpenSUSE's?

I have two hard drives on my PC, one is 1TB and the other is 250GB. On the 1TB one I have a rarely used Windows 8.1 and Tumbleweed installed (each get 500GB of space). On the separate 250GB hard drive I have an old version of Ubuntu installed that I don’t ever use lately. I just don’t want to delete it yet in fear of it messing my MBR.

This is the output of fdisk -l:

Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x0003b330

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1  *         2048     718847     716800   350M  7 HPFS/NTFS/exFAT
/dev/sda2          718848  943929343  943210496 449,8G  7 HPFS/NTFS/exFAT
/dev/sda3       943929344 1953523711 1009594368 481,4G  f W95 Ext'd (LBA)
/dev/sda5       943931392  952332287    8400896     4G 82 Linux swap / Solaris
/dev/sda6       952334336 1953503231 1001168896 477,4G 83 Linux

Disk /dev/sdb: 232,9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000b30dc

Device     Boot   Start       End   Sectors  Size Id Type
/dev/sdb1          2048   3999743   3997696  1,9G 82 Linux swap / Solaris
/dev/sdb2       4001790 488396799 484395010  231G  5 Extended
/dev/sdb5  *    4001792 488396799 484395008  231G 83 Linux

and this is a screenshot of the YaST2 partitioning tool(no idea what the tmpfs thing is).

When I boot up I get the Ubuntu bootloader instead of the OpenSUSE bootloader, which is the one I want to have. This is due to the fact that I installed Ubuntu before I installed OpenSUSE. How can I change this? How can I uninstall the Ubuntu bootloader and just install the bootloader of OpenSUSE?

On the Yast2 bootloader tool, it says that I have the GRUB2 bootloader is installed, but I think it’s confusing it with the GRUB2 bootloader of Ubuntu. I tried changing the option to “Not Managed” and rebooting, then changing it back to GRUB2 and rebooting, but nothing changed.

This is very crucial because every time the OpenSUSE kernel gets an upgrade, I have to log in to Ubuntu and update grub from there, which is tedious since I don’t even use Ubuntu.

It is unlikely to be making that mistake.

Go to that Yast bootloader screen. It should tell you where it is installed. It probably says that it is installed in the root partition. That would be worded something like “boot from root partition”. It might also say “boot from extended partition”.

You should be able to change that to “boot from MBR”. That should clear the other check boxes. Or manually clear them. You want it to say “boot from MBR”, “do not boot from extended partition”, “do not boot from root partition”, do not install generic boot code".

Once you have all of that set, you should be able to click “Continue” or “Finish” (or whatever, in bottom right corner). And, after that, you should booting directly into the openSUSE boot menu.

(I can’t easily check the screens here, because this is an EFI system with different information on the bootloader screen).

Do not forget that we have two disks here and YaST may have different idea what is the first disk than BIOS. Unfortunately TW dropped list selection for “Custom boot partition”, so one should at least go into Edit Disk Boot Order and verify that first disk is indeed BIOS boot disk.

It might also say “boot from extended partition”.

Does not appear to be offered by TW anymore.