How to remove UEFI secure Boot entry from Bios?


 Some time ago, upon installing opensuse, I accidentally chose to boot the usb in uefi mode. Since then I have had an opensuse secure boot entry in my boot options. I have already moved on, formatted the drive, etc. However, the opensuse secure boot entry still exist in the boot options in the bios. How can I remove it?

Thank you

I’m confused exactly what did you do??

Secure boot is a BIOS (EFI) option if it is turned on all OS’s installed must play by the secure boot rules. if it is turned off it does not matter what the OS thinks it can think secure boot is on or off it does not matter and will work in any case. No harm is done if the secure boot flag is set in the OS and not set in the BIOS. If secure boot is on in the BIOS you must have the secure boot on in the OS or it won’t boot.

Secure boot has absolutely nothing at all to do with the drive or partitions on the drive. So have no clue what you changed there.Did you remove openSUSE

To remove an entry can be tricky You must modify the EFI boot tables this can be done from Linux not at all sure about Windows. Also there is an entry in the EFI boot partition for each OS which you would have to hand remove. this partition is formatted FAT.

Note that it is good that you installed in EFI mode because mixing mode can lead to much confusion and problems. Alos the EFI boot entry has nothing to do with secure boot

So do you have some Linux installed now. If not you will have to search Windows boards for info on how to mod the EFI boot table

It is relatively harmless to leave it there unused.

The way to remove with opensuse requires that you be booted to UEFI mode. You can use a live image for that. Then try the commands:

# efibootmgr -v
######## that should give a list of UEFI boot options with numbers (hexadecimal 4 digit).
# efibootmgr -b NNNN -B
######## that should remove the entry with number NNNN

That may or may not work. On one of my computers, the firmware ignores and leaves the entry there anyway, unless I also remove the “opensuse” directory from the EFI partition.

Your firmware (BIOS) settings might provide an option to delete an entry.