How to remove a program unknown to 'Add/Remove Software'?

I recently installed RealPlayer following the instructions in
How to install and Configure Real player in OpenSuse | SUSE & openSUSE

The installation failed - aside from not being able to find any icon anywhere to start RealPlayer, other than going to my /opt folder in a file browser - RealPlayer crashed immediately.

I would now like to remove this defective program, but when I use ‘Add/Remove Software’ it is unable to find any reference to RealPlayer.

How to I remove it, totally and cleanly, rather than just deleting the RealPlayer folder in my /opt folder?

From real site

** Q. I installed RealPlayer using RealPlayer11GOLD.bin, without a package manager. How can I uninstall it? **

A. To cleanly uninstall RealPlayer11GOLD.bin, execute the following script and then simply removing the installation directory:
$ sudo -i


rm -rf /opt/real/RealPlayer/

and next time cross-eyed-bear, to install it TRY this:

-right click on the rpm
-choose “Actions”
-choose “Install with YaST”
-give root pass when asked

it is my understanding if you do it THAT way, YaST will automatically:

-solve all dependency issues
-enter the program in the menu system, so you can click the lizard
-list it in YaST and therefore provides an easy uninstall (click to

openSUSE is just too easy sometimes!

/( )\ natural_pilot

If you would have bothered to read the original post and/or provided link, you’d see that realplayer is distributed as a .bin file and not an rpm.

Reading posts is just too easy sometimes!

> Reading posts is just too easy sometimes!

excuse me!

/( )\ natural_pilot

Thanks for this advice - it seems imminently sensible… however,as in almost every install I have tried in Linux over the last 3 years, there is a fatal error: in this case there is no psotuninst script in the postinst folder -or in any other folder.

I think I’ll try installing it again to see if asecond attempt will provide me with an uninstall script.

Further to my previous post, OK, I have tried re-installing RealPlayer - without success. In fact the install log shows that no file named ‘’ is created during the install process.

So, back to my question: how do I uninstall a program that has been installed from a bin file?

At a rough guess, have you tried


might work


If you plan to install realplayer after removing. Try this

Open a terminal and go su and do: (copy and paste this):

rm -rf /opt/real/RealPlayer/

Then use the .rpm method I described earlier, was it in another thread or am I mixing you up with someone else?

rpm -ihv Package_name

I found an rpm here:

Nah - it won’t work - there is no real directory in /opt

I’ll try this, but first I have to figure out how to remove the existing mess.

It doesn’t sound like you ran the install as root, because you have no /real in /opt

So there should be little to worry about. What mess do you see exactly.