How to reduce the mouse scroll speed in KDE?


This has been asked a lot for over 10 years now and I cannot find any solution suited to the latest KDE on Tumbleweed.

I am still using xorg, as I can not come up with solution for reliable scaling in wayland… But slower scrolling is what I need, as I have very bad eyesight and need huge (!) fonts and GUI elements…

Now at the moment scrolling with the mouse moves lists in applications like dolphin, kate or others way to far up and down with only one single “step” on the mouse wheel… - I need to reduce it (scrolling too many lines makes me miss some lines completely due to scaled fonts!).

I know that KDE removed the option to have detailed mouse settings…

Old solutions of editing kdeglobals or xorg.conf do not aplly anymore.

What is the solution to change the scroll speed (formerly “WeelScrollLines”) to a lower number?

thx for reading,

For KDE (X11), there are a couple of options that can be used. The first is the easiest as it allows adjustment via System Settings. It requires that you switch to using the evdev Xorg driver. Install with

sudo zypper in xf86-input-evdev

The next time you login to KDE you should see the additional adjustable parameters available via System Settings.

The second method (using libinput) is more complex, as it requires you to create a custom input configuration file to change the necessary. I won’t provide further info unless you require it.

If libinput-tools is installed, you can get the available parameters for a given input device using

sudo libinput list-devices

BTW, KDE Plasma (Wayland) provides more control over mice, and fractional scaling works from my experience with it.


First of all: Thanks for helping!

Now, I guess the package you are takling about is “xf86-input-evdev” and it is already installed. But I do not have the additional settings - as far as I know KDE ditched them since about two years now…

I am aware that wayland offers better control in this area but consistent scaling is still a hurdle I cannot overcome with the latest wayland…

After installing libinput-tools I get:

sudo libinput list-devices 
Device:           E-Signal USB Gaming Mouse
Kernel:           /dev/input/event1
Group:            5
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   flat *adaptive custom
Rotation:         0.0

So I wasn’t aware this old mouse is supposed to be a “gaming” device… but , well, there you go… :slight_smile:

Sadly no “WheelScrollLines” parameter as mentioned in some older guides…

How do I get the options back if “xf86-input-evdev” is already installed?


With respect to the evdev approach, you need to make sure that the config file takes precedence over /etc/X11/xorg.conf.d/40-libinput.conf. The simplest way is to copy (or rename) 10-evev.conf to 60-evdev.conf, then the next time that the X-server is started you can confirm that the input devices are being handled by the evdev driver…

grep -i "using input" /var/log/Xorg.0.log

*It is possible to create a custom .conf file such that it is matched specifically to the device of interest.

Anyway, see how that goes.


Are you sure your approach still applies to the latest Tumbelweed?

The only file in “/etc/X11/xorg.conf.d” here is “00-keyboard.conf”.

grep -i "using input" /var/log/Xorg.0.log
26.943] (II) Using input driver 'libinput' for 'Power Button'
[    26.983] (II) Using input driver 'libinput' for 'Video Bus'
[    27.017] (II) Using input driver 'libinput' for 'Power Button'
[    27.042] (II) Using input driver 'libinput' for 'Logitech USB Keyboard'
[    27.066] (II) Using input driver 'libinput' for 'Logitech USB Keyboard Consumer Control'
[    27.090] (II) Using input driver 'libinput' for 'Logitech USB Keyboard System Control'
[    27.106] (II) Using input driver 'libinput' for 'E-Signal USB Gaming Mouse'
[    27.270] (II) Using input driver 'libinput' for 'E-Signal USB Gaming Mouse Keyboard'
[    27.300] (II) Using input driver 'libinput' for 'Eee PC WMI hotkeys'
[    27.344] (II) Using input driver 'libinput' for 'Logitech USB Keyboard Consumer Control'
[    27.345] (II) Using input driver 'libinput' for 'E-Signal USB Gaming Mouse Keyboard'

Any ideas?

The config files may be in /usr/share/X11/xorg.conf.d perhaps. (I’m still using Leap 15.4.)

Anyway, check

rpm -ql xf86-input-evdev

You can still copy the .conf file to /etc/X11/xorg.conf.d/ and it should take precedence when the X-sever is next started.

Hello again!

That has been the solution!

I copied the file
“/use/share/X11/xorg.conf.d/10-evdev.conf” to

… then restarted and as you described - now I get the evdev maouse configuration which offers to adjust the mouse wheel scroll speed from the default “3 lines” down up to “1 line”. And this immediatly takes effect and works!

So thanks a lot for helping - for me this is solved now (at least until I finally will switch to wayland…)!


Glad to have been of assistance! :slight_smile: