How to recover monitor setup

Hi there,
I have a mini box with Leap 15.4 installed. This was working fine until I had to disconnect the HDMI cable for another usage.
I have now reconnected it but when I boot, resolution is 640x480 instead of something like 1680x1024.
Moreover, there is no list of resolution in the Displays window.
This above was before I tried to fix it, now it’s worse.
I found a page
SDB:Configuring graphics cards and monitor settings
and tried to follow it. No succeed
I found another page
SDB:Configuring graphics cards
and I added “nomodeset” at the end of the line as wrote.
Unfortunately now my monitor stays black.
I can ssh but I don’t know what to do, I don’t want to break it more.
I’d guess I should remove the last “nomodeset” I added, but how as I don’t have access to the boot, nether to the graphic.
Let me know what info you need.

Thanks for your help

Where did you add it?

With Yast2, Boot loader Settings, Kernel parameters, Optional kernel Command Line Parameter
At the end of the line, same as
.... 5a1093 preempt=full quiet security=apparmor nomodeset

I don’t know how to remove it without GUI.

YaST offer text mode interface, just run yast and you get the same options. Or you can simply edit /boot/grub2/grub.cfg directly, just remove “nomodeset” everywhere you see it :slight_smile:

Thank you, I am back to the initial issue; Resolution 640x480 and no other choice.

> cat /etc/os-release
NAME="openSUSE Leap"
ID_LIKE="suse opensuse"
PRETTY_NAME="openSUSE Leap 15.4"

sudo lspci -nnk | grep -A3 VGA
04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd] (rev c3)
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:0123]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
04:00.7 Non-VGA unclassified device [0000]: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/Renoir Non-Sensor Fusion Hub KMDF driver [1022:15e6]
	Subsystem: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/Renoir Sensor Fusion Hub [1022:15e4]
	Kernel driver in use: i2c_amd_mp2
	Kernel modules: i2c_amd_mp2_pci

Boot delay is 10s but I can’t see the boot menu
Files in /etc/X11/xorg.conf.d/ 50-devices.conf, 50-monitors.conf, 50-screen.conf are with comment “#”
Any idea what I shoudl do?

Can you also show us the output from

inxi -SGa
kscreen-doctor -o
~> inxi -SGa
System:    Host: Kernel: 5.14.21-150400.24.55-default x86_64 bits: 64 compiler: gcc v: 7.5.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150400.24.55-default root=UUID=494c08cd-9aaa-4dec-acc2-13814fcae5b3
           splash=silent resume=/dev/disk/by-uuid/9ebf81e0-1f57-4d3d-8434-3da6e898daa6 preempt=full quiet security=apparmor
           Console: pty pts/0 DM: LightDM 1.30.0 Distro: openSUSE Leap 15.4
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] driver: amdgpu v: kernel bus-ID: 04:00.0
           chip-ID: 1002:15dd class-ID: 0300
           Display: server: 1.20.3 compositor: marco v: 1.26.0 driver: loaded: amdgpu,ati
           unloaded: fbdev,modesetting,vesa tty: 132x24
           Message: Advanced graphics data unavailable in console. Try -G --display

I run Mate desktop, don’t have kscreen-doctor.
I can install kscreen5 from the repo if needed. Let me know.

My bad. For some reason I thought you were using Plasma. Anyway, just run


and report back with the output.

~> xrandr
Can't open display 

Do you even have a working desktop environment?

If you cannot even see the boot menu, something more fundamental seems to be wrong. Did you try to unplug the power cable? Did you check all cables for being loose?

This is not a power on issue.
Yes I have the desktop but at boot I can’t see the menu that I have set at 10 seconds, screen is black.
After boot, Displays has only one resolution at 640x480 (I see only a part of the desktop window) and I don’t know how to set it for my monitor.

Can you enter BIOS setup?

Looks like system is not seeing the monitor thus using fall back values.

When I start the box and doesn’t touch, after about 20s the desktop appears.
When I start again the box, I can’t see BIOS countdown and when I hit Del key at start, nothing happen, black screen, no desktop after that.

Then how it is openSUSE problem if even your BIOS cannot output to display? I would ask on support forums for your system how to reset BIOS settings.

In Leap’s ancient inxi 3.3.07 version (from 18 months ago), -G is broken. Before using Leap’s inxi version for -G, it should be run with -U to update itself from upstream. Upstream is 3.3.26 as of now, but 3.3.27 release is due very soon.

I have a similar/same issue with a 4k LG TV when used with Intel i5-11400 Rocket Lake graphics on an Asus PRIME B560M-A motherboard. The TV will never light up using only the PC’s default video, so there’s no POST output, screen is black in BIOS setup (assuming BIOS setup was ever reached), and early init is just a black screen. In order to see a POST screen or a Grub menu I need to connect a second (e.g. 1920x1080) display before power-up.

Thank you all of you for your help.
I at least found what was wrong.
My old Philips monitor (18 Years old) is the culprit. It can’t get the right resolution. I got one new monitor and everything is working fine.
I never thought it could fail on sync and keep the screen working.
Tested with another computer I got the same issue. Good for the recycling.

So, thank you, good luck to all.

Thanks for the update. It was likely not reporting its EDID to the graphics card properly, or at all.