how to recover login/password after upgrade

i got myself in a really dumb position. i upgraded from 11.0 to 11.2 this morning. after restarting it loads up everything and then shows me a login/password prompt. i have forgotten what my login is, i know my password.

is there anyway to find the login name?

Hash: SHA1

If you have root access its easy to see your login name, if not you
better ask to your system administrator

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


> is there anyway to find the login name?

is it a GUI login prompt, or CLI?

if CLI

  1. log in as root and nav to /home and look at the name of the user
    (same as the name of the directory there)

if GUI:

  1. boot from a live cd, mount the home partition and look at the name
    as in 1


  1. at the first boot screen type 3 hit enter and do as 1, then log out
    as root, log in as user and do startx

is that enough?


Use a live CD to boot the computer. If you don’t have a live CD, only an installation DVD, then boot that and select to “rescue system” (that is an elementary Live CD).

Mount the home partition if you have one, or the root partition if you don’t have a home partition.

If you’re using the live CD: Using Nautilus, browse to the mount point, then to the directory “home” and you’ll see the username/s.

If you’re using the installation DVD: use cd and ls to list the subdirectories in the directory “home” and you’ll see the username/s.

it looks like it is wanting the root login and password. i can get into the failsafe mode just fine, and when i opened yast it accepted my password. i found my user login name, but it will not accept it with the login prompt. it is a CLI prompt. the problem now is that i dont have the root login/password. dont recall where i marked it down at. i dont recall this type of a process when i updated from 10.3 to 11.0.

i figure that i will just do a clean install. so my question now is:
i have dual boot. will a clean install cause any problems? will i have to mess with the grub boot loader or will it just deal with the opensuse partition and everything else will be okay?

thanks for all your help so far.

Should not be a problem. Just be sure the partitions are mounted to the right points and Don’t reformat /home.

You can reset your root password using this tutorial:
How To: Recover the Linux root password

great link, it worked.

now i can log in with a CLI, but there is not GUI. when i log in it tells me to have a lot of fun and then just leaves me at a red prompt. dont know what to do from there, or how to get a GUI working. help please, and thanks for everything up to now.

things seem a little too crazy for one with too little experience and know how (though that is why most of you are here to help). so i am going to reinstall and start anew.

thanks again for all your help.

Hash: SHA1

Without CD/DVD you add init=/bin/bash to the grub kernel line and you
start a root shell you can use to reset the password


Microsoft Windows is like air conditioning
Stops working when you open a window.
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


i got the password reset. now the problem is that every time i start up into the normal (not failsafe) mode i get the CLI and i have no idea what i am doing in that mode. i tried an update installation (11.2 to 11.2) in hopes that it would correct this but it didnt happen (there is another thing i was hoping to fix, i accidentally got rid of the main toolbar from the bottom and cant figure how to get it back right now). when i boot to failsafe mode it goes into the KDE GUI, but will not for normal boot.

i havent searched to see if there is any solution to this problem yet, if any know please let me know. that will save me the questions that will be coming up for the new installation.

Now the problem is with video drivers. Do you have an Nvidia card or an ATI or other special video card?

Also, try the command startx at the prompt.

i figured it was with the video drivers, i read somewhere about nvidia drivers with the newest kernel, something like that. i have an nvidia card. i did try startx, but it kind of kicked me out. the only thing i remember is that it got to level 11, something like that. i will record what the output is and post if it may be of help.

i did get into the gui through failsafe, and had my computer connected by cable to the internet. i was trying to use yast2 to add repositories, etc. to install what i figured i would need, but it wouldnt run the package manager program to allow me to add.

suggestions/guidance at this point would be great. i cant thank you all enough, swerdna specifically (you have helped me with other issues in the past), and all others that have helped me in my times of need but i will try. thanks so much.


I don’t understand why you can’t add a repo in failsafe mode, but let’s proceed anyway, and see what happens. Please report back here three pieces of information. Boot to the console and log in as root.

  1. Find out what card you’ve got with this command:
 lspci | grep VGA 
  1. Find out your kernel with this command:
uname -r
  1. list your repositories with this command:
zypper lr

When you report the returns that you get, we can see what to do (hopefully – unfortunately I don’t have an Nvidia card)

  1. first i went to failsafe and opened a terminal and didnt get anything. then at CLI it recognized nvidia G84(GeForce 8600M GT)


  3. OpenSUSE 11.2-0 Yes No

  4. repo-debug No Yes

  5. repo-non-oss Yes Yes

  6. repo-oss Yes Yes

dont recall the exact column headings for the Y/N answers. first starts with E, second with R.

You have the “desktop” kernel variant.
The GeForce 8600M Gt requires the following RPM packages (re “desktop” variant):
The repo is this one:

That’s the key info. Now there are four steps:
[li]boot into the console version, never mind the failsafe, be sure to log in as root[/li][li]add the nvidia community repository[/li]issue this command in the console make no typos, maybe copy/paste:

zypper ar -cf -n 'Nvidia112' Nvidia112

You should gat a dialogue with no errors. Then run this command to see if it worked:

zypper lr

you should see similar to this line amongst the list:

Z  | Nvidia112   | Nvidia112     | Yes     | Yes

[li]start yast in ncurses graphics mode and cruise to the software manager. Run this command to start Yast in simple mode:[/li]


Navigate with arrow and tab keys to activate “software management” on the right hand side. Use “nvidia” in the search phrase box. Tab and arrow to the RPMs
[li]select and install the nvidia RPMs nvidia-gfxG02-kmp-desktop and x11-video-nvidiaG02. Pressing “Enter” key will toggle selections on and off. Tab to bottom right hand corner and highlight “Accept” and press “Enter” Key to make it happen[/li][/ol]

After they’re installed, reboot and see what happens.

completed 1 and 2, but i am not familiar with ncurses so 3 and 4 are incomplete. i did a search for ncurses to see if i could find how to use it/what it is but havent found anything yet. i will search some more, if i could get a link or some direction on this i would appreciate it.

i did get similar output from zypper lr, so the first two steps worked as noted.

got the ncurses thing figured out, just never heard of it before.

i was able to navigate yast in ncurses and everything is good. installed the correct drivers and i am now working in GUI in normal boot.

swerdna, you are officially one of the greatest.

now one last question that is off topic. how do i reset my desktop/toolbar at the bottom? i accidentally deleted it and so i dont have all my desktop panels available, etc.


Several ways to do it.

  1. Right click desktop. Select unlock widgets. right click again and add panel. You woulds then need to add the widgets you want to the new panel

  2. Press CTRL-ALT-F1 to go to a terminal. Log in as your self. Become root with su -. Type init 3 to shut down the GUI. Navigate to home directory **cd /home/**usernamehere. Type cp .kde4 .kde4old. This removes the KDE configuration and will force KDE to go to the default setup. Type init 5 to restart the GUI. Youshould now have a new desktop with all the default new install things. Because we left the terminal running as root we should shut that down. So type Press CTRL-ALT-F1 to go to a terminal again and type exit twice. Press CTRL-ALT-F7 to go to the GUI.

  3. Create a new user and use that account.