How to prevent Windows 10 from taking over Grub and BIOS Config?

Whenever I press F8 and boot into windows 10, Windows changes my BIOS settings, GRUB settings and just boots itself over and over. The only 2 ways I have found to take back control over my computer is to re-save my bios boot order and to actually disconnect The Windows 10 Hard Drive to work with my Linux OS’s. Does anybody know of a way to prevent Windows from taking over my computer and just booting itself over and over?

Are you using legacy BIOS or EFI boot?

It must be legacy BIOS. I am concerned about changing or upgrading my current BIOS firmware because I don’t want to loose even more control over my computer and I don’t want to inadvertently break something else by upgrading, which sometimes happens.

Only way I found: Stay on Win 7. No joke.

I have some dedictated hareware in special networks for win 10 and some win 10 VMs on linux.

Then I can only think about installing Linux bootloader on a different disk (assuming you have more than one) and using BIOS menu to select boot from different disk. OTOH F8 is usually used in Windows to troubleshoot/fix boot problems, so may be more simple solution would be “do not do it”?

I have installed 4 operating systems on 4 different hard drive which are all inside of my desktop and all connected to the motherboard simultaneously. I have found out through some failed installs, that none of the operating systems play nice with each other when I try to install an new OS on a different hard drive. So, I installed each OS one at a time with the other 3 hard drives completely disconnected during the installation of a new OS. openSUSE, Windows 10, EDUBUNTU, and LUBUNTU all exist together fine, but whenever I choose to boot up Windows 10 it changes my BIOS setting and it keeps booting itself.
I don’t find pressing the ‘delete’ key during the BIOS splash screen and re-saving my intended boot sequence overly burdensome, however, I am troubled that Windows 10 programmers think it’s okay to keep changing my BIOS setting without asking me or notifying me. It seems like Windows 10 programmers are taking control over my computer without asking me. I wonder what other usurpation Microsoft is taking?

And the reason you are posting it in the Linux technical support forum is … ? Why do not you raise it up where it belongs?

1 Like

Why do you F8? It has different meanings on different PCs at different times with different operating systems and different applications. At POST time, it might be a BBS hotkey (for choosing a boot device), which differs across different computer brands. e.g.:

ASRock		F11
Asus		F8
Biostar		F9
Dell		F12
eCS		F12 or F10
eMachines	F10
Gigabyte	F12
HP		F9 or ESC or ESC,F9
Lenovo		F12 or F8 or F10
MSI		F11
Toshiba		F12
1 Like

Appologies, @arvidjaar , for ranting a little. Thanks for calling me on it. I seriously was hoping to learn a Linux openSUSE method for programming my BIOS to default to always let me choose which device to boot out of the 4 that are installed.
I was using F8 on my ASUS Essentio, @mrmazda , mostly because it’s the only hot key I know to bring up the menu of which device to boot.

Yesterday I had the same experience, after the Win10 upgrade/update .

Go to F2 Bios and change the order of boot device from
Windows boot loader on top to Opensue on top.

Save and restart, openSUSE grubs should boot.

just did this on my Asus laptop.

Edit, you always disconnect the drives and then use them each at a time? I this case win will always grab the EFI boot. No need to disconnect, and also no need to install with harddrives disconnected. I tripe boot
And make just sure that the bootloader and EFI partition is installed to the correct drive. As Linux does also start win, this is not an issue

1 Like

That should do the trick, changing the device order, but Windows 10 still makes itself boot #1 even though I prioritize #2 or #3. I don’t have to disconnect all my devices, that would be a really huge pain. The only other thing that seems to work in my situation, there always seems to be at least one working method in Linux, is to shut downd my computer from windows. Then once the computer is actually off, Windows does a lot of hard drive stuff after the screens shut off, I flip the off switch on the back of my computer. Then, after 5 seconds, I switch it back on. Then toward the end of the BIOS splash screen I press and hold F8. Then my 4 devices pop up on screen and I can choose which device I want to boot. It’s kinda tricky, but it’s doable. If I could program my bios the way Windows seems to be able to then I wouldn’t have to do all those tricky things to have control over my computer.

Did you try to disable fast startup in Windows?

1 Like

Thanks, @arvidjaar . I managed to turn off fast start and now when I press f8 I can choose my operating system.