How to prevent self-adjusting icon size?

Does anyone else find it irritating that the size of icons adjusts automatically in desktop panels or in Dolphin’s places panel?

In desktop panels, I’m referring to icon size of widgets, of tasks in the task bar, or of the Lancelot launch item. (Funnily enough the icon size of the traditional application launcher doesn’t change when adjusting the panel size … )

I’m using a rather wide, self-hiding vertical panel on the right, which I find convenient for keeping track of tasks in the task bar, but because of its widths many icons are just unbelievably HUGE.

Same with the places panel in Dolphin.

Is this a bug & worked upon, or is it intentional?
How can I switch it off / set a default size?

I’ve tried 2 things, both in vain:
(1) Adjusting the icon size under Personal Settings > Appearance > Advanced (but am apparently not allowed to change it).
(2) Changing icons to a smaller size, such as 22x22. Doesn’t work, though, because they are still blown up, and a low-resolution icon blown up certainly doesn’t look pretty.)

Cheers

homoludens

Nope, it’s quite essential when you want a narrow panel.
Why do you make the panel so big when, clearly, you don’t want the icons to be?

Because the panel isn’t just a place for neat looking icons but also for text-based information. For example, a wide, vertical task bar provides you with a quick and systematic overview over all open windows. Essential, for instance, when you have 30-40 browser windows open. Why don’t you give it a try, you might discover a new world of efficient window management.

Anyway, this clearly doesn’t work very well when oversized icons swallow up all the space.

Well, i never have that many windows open (Opera has this wonderful thing called tabs :wink: ) so having the task manager hidden at the bottom suits me just fine. But i can see where you’re coming from.

True, the ability to resize icons/plasmoids would be welcome. I personally hate how some plasmoids take up any width available.