How to prevent initrd to fsck my swap partition?

First of, thx for reading and answering my post if you can.

Whenever I boot my PC, the preboot system in initrd launches a fsck on my swap partition, whereas all the fs_passno in fstab are set to 0, including the swap partition.

So I must ctrl-alt-del several times my PC until I get a normal boot, which is a tedious process.

How can I avoid this nightmare ?

Hi skylendar,

First it would be best if you showed you full fstab so experts can check for issues:

kasi@pluto:~/Schreibtisch> cat /etc/fstab
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /                       btrfs  defaults                      0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=cdec8455-ef44-4f5e-beb8-71213d9071ed  swap                    swap   defaults                      0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /var                    btrfs  subvol=/@/var                 0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /root                   btrfs  subvol=/@/root                0  0
UUID=57e6092c-fa17-40bb-980e-6528d58c488d  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=e5cd1f6e-b8da-416c-8c16-04487604ca03  /home                   xfs    defaults                      0  0

Just a shot in the dark: Is there some spacers in the “swap” line which don’t belong there? fs_passno must be set in the sixth field, maybe it’s wrongly interpreted / a wrong digit taken for it?

Are you sure?

Therefore, the Linux Kernel kicks off fsck on your Swap partition …

  • Please check your installation –
 # zypper verify
 # rpm --verify --all

Please indicate which Kernel you’re using.


Which file system are you using for the system partitions?

LABEL=Root                                 /                       btrfs  defaults                      0  0
LABEL=Root                                 /var                    btrfs  subvol=/@/var                 0  0
LABEL=Root                                 /usr/local              btrfs  subvol=/@/usr/local           0  0
LABEL=Root                                 /tmp                    btrfs  subvol=/@/tmp                 0  0
LABEL=Root                                 /srv                    btrfs  subvol=/@/srv                 0  0
LABEL=Root                                 /root                   btrfs  subvol=/@/root                0  0
LABEL=Root                                 /opt                    btrfs  subvol=/@/opt                 0  0
LABEL=Root                                 /home                   btrfs  subvol=/@/home                0  0
LABEL=Root                                 /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
LABEL=Root                                 /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
LABEL=Root                                 /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=b488c454-4a06-4bfa-8b90-b18766c934c5  swap                    swap   defaults,passno             	0  0
UUID=bfe5a862-45a7-46e6-a54a-cac37d844dca  /mnt/ex                 ext4   ro,data=ordered,noauto        0  0
UUID=47433d40-a1a1-4ea9-ac53-d21de1358518  /mnt/b                  ext4   data=ordered                  0  0
UUID=F6F88C2FF88BEC65                      /windows/E              ntfs   fmask=133,dmask=022,noauto    0  0
UUID=8E7A489F7A488645                      /windows/C              ntfs   fmask=133,dmask=022           0  0
UUID=af5b2a3e-b38e-43f1-bea8-fd240676990d  /mnt/backup             ext4   data=ordered,noauto           0  0
UUID=C30F-1ABD                             /windows/D              vfat   fmask=133,dmask=02            0  0

As to zypper --verify: all seems ok

What is passno option? I have never heard about it.


man fstab
   The sixth field (fs_passno).
       This field is used by fsck(8) to determine the order in which filesystem checks are done at boot time. The root filesystem should be specified with a fs_passno of 1. Other filesystems should have a fs_passno of 2. Filesystems
       within a drive will be checked sequentially, but filesystems on different drives will be checked at the same time to utilize parallelism available in the hardware. Defaults to zero (don’t check the filesystem) if not present.

It’s the last zero in the line:

UUID=b488c454-4a06-4bfa-8b90-b18766c934c5  swap                    swap   defaults,passno             	0  0

Better delete that “passno” entry and try again.

deleted passno, made a mkinitrd and cold reboot. It seems to work with cold reboot, but not when hibernate/thaw up. But as I really prefer to hibernate…

as to the kernel, it is vmlinuz-5.14.21-150400.24.49-default, but it doesn’t work whatever kernel I choose.

about passno: it is wtitten in the systemd-fsck manpage that:
These services are started at boot if passno in /etc/fstab for the file system is set to a value greater than zero.
So, I thrived to setup the passno to 0. But nothing seems to work.

The “passno” in that man page refers to the number in the last column. It is already 0 (for swap) in the “fstab” contents that you posted.

you’re right, but it doesn’t solve my problem.

Ah, and I forgot:

I also did:

mkswap /dev/sdb7

but nothing changes.

also, I installed the same 15.4 from the same dvd on my laptop, but this time, I don’t get this behavior. It works fine.

Perhaps the BIOS on the affected computer does not adequately support hibernate.

Good explanation, but it worked before. This phenomenon suddenly appeared, and I don’t remember having done something weird with my linux config.

Does that UUID refer to a physical partition or some kind of logical volume?

physical, = /dev/sdb7