How to play music

I have just loaded Suse 13.2 and am using the Gnome desktop.

If I open Music I am greeted by a white page telling me there is no music.

If I put a disc into the CD drive, a pop up box allows me to burn or copy a CD, but nothing more.

How do you play and rip music using this application?

I’m clearly missing something obvious, but I have run out of things to click on to make anything happen.

Did you read (and follow) the first, sticky, thread in this sub-forum?

It is this one:

Hi Henk,

I had completely forgotten that the Suse operating system requires lots of additional input :slight_smile:

Can you please just confirm that the ONLY part I have to install is the one-click Gnome Codecs.

There are several additional drivers below that, but do I need those, too?

Many thanks.

I am not using Gnome, but I think the action is universal. What I do is:

  1. add the Packman repository: YaST > Software > Repository Management, then Add, d comunity select Packman and add.
  2. YaST > Software > Software Management and then from the View menu > repositories. Then select Packman and click on the textt above the list of packages, which reads something like" Change installed packages to the ones in this repository.

That will replace all packages which are in the OSS repo and also in the Packman repo to those in the Pachman repo.

When in he future you decide to install some other media player, this switch action might need to be repeated for newly installed codecs.

An extra is the libdvdcss2 package, that should be installed from the libdvdcss repo in the same way.

Hi Henk,

I had to take a break from installing 13.2, but I am now back.

I have installed 13.2 and also undertaken your one-click multimedia install (as per your slide show).

Unlike in previous installs of Suse, there does not appear to be a media player installed as a default - as was the case with Rhythmbox on an earlier version of Suse that i have used.

The only thing that tries to play my CDs is Brasero.

So, my question is this: how can I put an active CD and video player in place in 13.2? If there is a media player now installed somewhere, can you tell me step-by-step how to put this into operation?

I interact with the operating sysetm so rarely that I don’t know how.

Many thanks for your patience.

I am a KDE user and default I get at least Amarok and Kaffeine. I think I added VLC myself. I do not know what is installed in a default Gnome installation, but there must be enough, but (after the switch to Packman) not very many people report problems here.

Maybe wait for a Gnome user to tume in here for a better answer.

No worries.

I looked under Software Management and there are several VLC mentions, some of them “VLC Gnome”. I don’t really know what I would be doing, but how many of these VLC boxes need to be ticked? What would I then have to do?

Can anybody help?

I would check vlc in any case. It will draw in automagicaly what it needs from the others. As Gnome user you may want to add gnome-vlc (does not matter if you do not realy need it).

But check in the Version tab below the list if you go for the Packman version.

When you made your selection, cllick Accept low/right and prrrrrrtttt…

Ok, so in the Packages, I seem to have multiples of everything for no apparent reason.

So, for anything starting with VLC, I have loads of variants…


Which of these should I tick in the box before actioning? I’m guessing not more than one of each, but surely not one from each set?


I suggest you go through the manual installation given at It has specific instructions for Gnome. For some reason, this seems more reliable than one-click. Read all the steps and the IMPORTANT NOTES part way down the page.

Before starting, make sure the VideoLan repository is NOT enabled. It would probably also be well to uninstall all packages of VLC. Any needed ones will come in with the above procedure.


Hi Howard,

Many thanks for that. I will do the manual install, but first I need you to help me with the following.

If i go into SOFTWARE/VIEW/REPOSITORIES/PACKAGE VLAN is ticked, so I supposed this is enabled. What do I now have to do to disable it?

Also, if I go into PACAKAGE GROUPS and find MULTIMEDIA this is where all the unticked VLC pacages currently are. What do I have to do to eliminate these prior to the manual install you mention?

Many thanks for your patience.

No. You should go into YaST->“Software Repositories”, and remove the VideoLAN repository if it is in there.
Then you should add the “Packman Repository” if you don’t have it already, by clicking on “Add”, choose “Community Repositories”, and enable it in the list.

Afterwards, go to YaST->Software Management, remove all vlc packages (you have the beta version installed, not sure whether this is a good idea). Then install vlc (not vlc-beta) and vlc-codecs (this will probably not be selected by default).
And probably do a “full repository vendor change update” to Packman to be sure all packages come from there.

If in doubt, please post your repo list:

zypper lr -d

Thank you very much for your help.

First things first: here is my repo list. I do believe the Packman repository is already enabled and that the VideoLAN repository is not. Would that be correct?

1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | |
2 | | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | |
3 | | Main Repository (OSS) | Yes | Yes | 99 | yast2 | |
4 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | |
5 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_A |
6 | repo-debug | openSUSE-13.2-Debug | No | Yes | 99 | NONE | |
7 | repo-debug-update | openSUSE-13.2-Update-Debug | No | Yes | 99 | NONE | |
8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | |
9 | repo-source | openSUSE-13.2-Source | No | Yes | 99 | NONE | |
10 | repo-update | openSUSE-13.2-Update | Yes | Yes | 99 | rpm-md | |
11 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | Yes | 99 |


I would suggest to run this then:

sudo zypper rm vlc*
sudo zypper in vlc vlc-codecs
sudo zypper dup --from 1

VLC should work then.

IIUYC, you were originally talking about gnome-music, right?
You’d need some additional gstreamer plugins for that I think. Try to install gstreamer-plugins-bad-orig-addon, gstreamer-plugins-ugly-orig-addon and gstreamer-plugins-libav, this should cover everything.

And about the problem that it doesn’t show any music at all: AFAIK it only shows music files that are indexed by tracker. So make sure your music is in a directory that’s indexed.
I cannot help you more with that though, I don’t use neither GNOME, nor tracker, nor gnome-music.


Many thanks for the post.

I just want to be totally clear. Before going any further, should I still eliminate all the various VLC files that I already have?

I so, how exactly do you do this? I found them through Package Groups > Multimedia and then the list on the far right, where the various references to VLC had a box, which I could tick, but I wasn’t sure how you then deleted these, especially since there were other things ticked further up the list.

What “files” do you mean now?
There should be any need to remove the VLC config files.

And those lines that I gave you remove all vlc packages.

You could of course just search for “vlc” in YaST (View->Search) and mark all of the packages for uninstallation manually, and then installing vlc and vlc-codecs again afterwards.
To uninstall a package in YaST, click on the box until it has a red X. See also in the menu: Help->Symbols.
Or right-click on the package and choose “Remove”, or select the package and choose “Remove” from the “Package” menu.
There’s also the possibility to remove “All in this list”.

I cut and pasted what you suggested in a terminal and got a message back: “No package matching vlc* is installed”.

What did I do wrong?

Ignore that! It worked! wolfi you are a genius. Thank you very much for all your help!

Merry Christmas!:wink:

my take is to not change the vendor from opensuse to packman, i had problem with amarok from packman, due to the libtag, it did not start anymore.
other than this, you will receive a lor of rebuilds as updates.
i am using kde and i use the “phonon-vlc-backend”. i did not bother with “1-click-install” anymore. i only add the packman and install vlc, vlc-codecs and phonon-vlc-backend.

If you switch libtag to the Packman version as well (which you do of course if you “Switch all packages” in YaST or run “zypper dup --from xxx”), amarok will work fine.
The problem is just that amarok from Packman needs the newer libtag from Packman.

Note that this is no issue on 13.2 anyway, as 13.2 comes with the newer libtag so also the standard amarok is built against this.

other than this, you will receive a lor of rebuilds as updates.

Not really.
Most of these “problems” have been fixed by now.

And if you want to use other applications than VLC with full multimedia support, there’s not really a way around that.

i am using kde and i use the “phonon-vlc-backend”. i did not bother with “1-click-install” anymore. i only add the packman and install vlc, vlc-codecs and phonon-vlc-backend.

That’s what I do since years.
Btw, you don’t really need phonon-backend-vlc from Packman. The standard one will just work fine with Packman’s vlc.
But of course the Packman package is a newer version…